Results 1 to 8 of 8
  1. #1
    Join Date
    Nov 2002
    Location
    Belgium
    Posts
    243

    Unanswered: Database already in use

    I have 2 databases (main.mdb and sub.mdb)
    The users are supposed to open sub.mdb.
    This DB gets its data from main.mdb

    But, when main.mdb is opened on another computer and the user wants to open sub.mdb then it gives an error that main.mdb is already in use.
    Once main.mdb is closed, it works fine.

    It is not an option to leave main.mdb closed, because it used by other people.

    Is there any solution to solve this problem?

    Thanks.

  2. #2
    Join Date
    Nov 2003
    Posts
    7

    Wink Re: Database already in use

    You should check that main.mdb is not opened exclusivle from any user, otherwise no other user not sub.mdb can open the database.



    Originally posted by artemide
    I have 2 databases (main.mdb and sub.mdb)
    The users are supposed to open sub.mdb.
    This DB gets its data from main.mdb

    But, when main.mdb is opened on another computer and the user wants to open sub.mdb then it gives an error that main.mdb is already in use.
    Once main.mdb is closed, it works fine.

    It is not an option to leave main.mdb closed, because it used by other people.

    Is there any solution to solve this problem?

    Thanks.

  3. #3
    Join Date
    Nov 2002
    Location
    Belgium
    Posts
    243

    Re: Database already in use

    Originally posted by alekizoglou
    You should check that main.mdb is not opened exclusivle from any user, otherwise no other user not sub.mdb can open the database.
    I checked under Tools>Options>Advanced>Standard modus = Shared.
    Is this what you mean?

  4. #4
    Join Date
    Nov 2003
    Posts
    7

    Re: Database already in use

    Originally posted by artemide
    I checked under Tools>Options>Advanced>Standard modus = Shared.
    Is this what you mean?
    No,

    When you open a database from MS Access you may either open in exclusively, or in read-only mode or shared. Try opening MS-Access ten File->Open->

    If you check the Open Button has a drop-dow list by which you can do the previous.

    I remember there is an option not to allow exclusive opening the database in MS-Access environment. You should check this out as well.

  5. #5
    Join Date
    Sep 2003
    Location
    Texas
    Posts
    20
    I'm going to stick my neck out here and assume that each workstation has MS Access on it. I'm also assuming that subdb is also copied to each workstation.

    One of your users has their Access application defaulting to open a database exclusively. If that workstation is the first to open the database, no one else can get on, except in read-only. Is this the case?

    However, if someone else opens the database first, it's "shared" and anyone can open it.

    Could this be what's happening?

  6. #6
    Join Date
    Nov 2002
    Location
    Belgium
    Posts
    243
    Originally posted by RichardTX
    I'm going to stick my neck out here and assume that each workstation has MS Access on it. I'm also assuming that subdb is also copied to each workstation.

    One of your users has their Access application defaulting to open a database exclusively. If that workstation is the first to open the database, no one else can get on, except in read-only. Is this the case?

    However, if someone else opens the database first, it's "shared" and anyone can open it.

    Could this be what's happening?
    When you open a database by going to File>Open, you have the possibility to choose between Open, Open Exclusively, Open Read Only and Open Exclusively Read Only, but I don't see any Shared in the list.

    Second point: when you open your database by doubleclicking, you don't have the possibility to choose your open-modus.
    Therefor (as far as I understand) you can choose your default open-modus in Tools>Options>Advanced>open-modus = shared.

    The two databases are located on a server and there are only two people who want to work with them (one person uses main.db and the other should use sub.mdb), but for the moment we get the 'already open'-error.

    One of my colleagues mentioned you have to use workgroupfiles when you work with shared databases, but I doubt it.
    Can anyone confirm or deny it.

    Are there still any ideas how to solve this?

  7. #7
    Join Date
    Sep 2003
    Location
    Texas
    Posts
    20
    You didn't mention whether or not you checked the default for shared or exclusive on each of the two workstations. You want shared to be the default on both. Even though the databases are on the server, they're still being run by the application on the desktop. Am I right? Or are you running Access on the server? Check that, too.

    Good luck.

  8. #8
    Join Date
    Oct 2003
    Location
    Boston, Mass. USA
    Posts
    81
    > When you open a database by going to File>Open, you have the
    > possibility to choose between Open, Open Exclusively, Open Read
    > Only and Open Exclusively Read Only, but I don't see any Shared in
    > the list.

    It doesn't say shared but the "Open" means shared (when it doesn't have the word "exclusive"

    Ideally users should open the database by clicking on a shortcut on their desktop or start menu. More advanced users, if necessary can double click the MDB itself in My COmputer/FIle Manager. TRy to discourage people from using File Open as I've seen novices accidentally open it exclusive.

    > Therefor (as far as I understand) you can choose your default open-
    > modus in Tools>Options>Advanced>open-modus = shared.

    Make sure that EVERY PC that access these databases has this set to shared.

    Also on every PC you can try Tools, Options, Advanced Tab and change"Number of Update Retries" to the maximum of 10.

    > The two databases are located on a server and there are only two
    > people who want to work with them (one person uses main.db and
    > the other should use sub.mdb), but for the moment we get
    > the 'already open'-error.

    Is the user using sub.mdb running Windows 98? Occarionally that can be a problem. Can you replicate this problem from another computer?

    Possibly try to put the sub.mdb on the one users machine and see if this works better than on the network.

    When you get the Alrady open error, try this. Look in main.ldb (user MS Windows or a text editor) and see if it shows any machines as logged in to main.mdb who are not in it att he moment. If so see if you can have the refresh interval on your server changed so it checks to see if the user is still logged in more frequently. And/or have everyone close out of both main.mdb and sub.mdb and open it again. that may do the trick . . . at least sometimes.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •