Results 1 to 3 of 3
  1. #1
    Join Date
    Nov 2003

    Red face Unanswered: Help with tab controls !! Thx

    I just want to create a simple form with 2 tab controls, each of which would set focus to existing forms, but can’t seem to get around it. Right so here is what I did.

    I created a main form in design view and added tab controls using the toolbox.
    This brought up a blank ‘form’ with page1 and page2
    Then using the subform / subreport button I inserted an existing form in page 1.
    Up to there everything works fine. But then when I click the page 2 tab control nothing happens.
    It doesn’t set focus to a blank page 2 where I’d like to insert another form.

    Can someone tell me what I’m doing wrong ? Are there properties that I should set on to use tab controls ?

    Also I noticed that if instead of inserting an existing form as subform I use ‘an existing table as data for my subform’ everything works fine.

    Thanks for your help,


  2. #2
    Join Date
    Oct 2003
    When creating your subform using the subform tool, you managed to put the sub form onto the main detail and missed the tab. Either use the wizard or when you drag the subform tool, the tab should turn dark grey. When that happens you should be fine. Just in case, make sure the tabbed form is larger than the sub forms before creating the sub forms.

    I have had this problem too and it can be a bit frustrating.

  3. #3
    Join Date
    Nov 2003


    Many Thanks jmrSudbury !! That was exactly my problem !! I really spent hours figuring this out to no avail

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts