Results 1 to 3 of 3

Thread: export via oem

  1. #1
    Join Date
    Nov 2003
    Posts
    4

    Unanswered: export via oem

    Hi all!

    Having problems with Oracle oem export. I am running Oracle versions 805 and 817 on a Windows 2000 pro box. I have in the past been able to import to the 805 instance but until recently (don't know when) this process has stoped working. I am using the 817 oem to process an export for both 805 and 817. The oem logs have been working to the point that I have stopped viewing each log individually to see what has been backed up (BAD). I have assumed that since the History window showed Compleated by each task everything was working well. This morning I tried to process an import only to find out that both of my exports ( 805 instance and 817 instance) have been exporting the data from the 817 instance. The actual dmp files have not been exactly the same size (differ by 300 - 700 k) which I also find disturbing/confusing.

    When the oem import failed (stated that the user not found in export file) I tried to do a manual import using a cmd window. After setting the sid (set Oracle_sid=des) I ran both imp80 ( 805 import ) and imp ( 817 import ) only to get the following error:

    Export file created by export : v08.01.07 via conventional path
    imp-00069: could not convert to environment national character set's handle
    imp-00000: import terminated unsuccessfully

    With that I checked the nls setting for both and found that both are set to the same:
    nls language American
    nls teritory America

    Any help would be greatly appreciated.
    Thank you in advance

  2. #2
    Join Date
    Nov 2003
    Location
    Bangalore, INDIA
    Posts
    333

    Thumbs up

    Hi,

    In general, export files generated by a higher version of the database are not backwards compatible. Try this

    From the 805 $ORACLE_HOME environment:

    exp system/manager@V817db file=... full=y ...

    Please also ensure that the export file is handled as a binary file if you need to transfer it from one host to another.
    SATHISH .

  3. #3
    Join Date
    Nov 2003
    Posts
    4
    Yes the manual export from cmd line does work. The problem that I am having is with the oem. For example, you can select to export a specific user. In the oem it does show the different user accounts (sys, desowner, test, etc) if I try and select just to export desowner by way of the oem all i fine until the job is submitted. In the oem history i will see the message "failed to loacte desowner for export" (or something very close to that message, not exact). Some how even though you can select a particular account when it goes to actually run the export it connect to the other database- 817 not the 805. Something tells me that this is more of a ms2000 issue mabe even registry problems?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •