Results 1 to 2 of 2
  1. #1
    Join Date
    Nov 2003
    Posts
    6

    Unanswered: Can't add fields to table in EM - Odd SP3a prob?

    Ok, I think this is a SP3a issue but I wanted to know if anyone else had this same problem.

    I am trying to add fields to an existing table but everytime I do, I get a message saying:

    'Races' table
    - Unable to create index 'IX_Races2'.
    ODBC error: [Microsoft][ODBC SQL Server Driver]Invalid cursor state

    I have narrowed it down to this. I can add the field if I add it to the bottom of the field list AND make it allow NULL. BUT...if I try to move the column up to another position (no, I don't need it in that position I know), it throws the error.

    Also, if I add the field to the bottom of the field list, then try take off the NULL and fill in a default value, it still throws me this error. Someone tell me that this is just a SP3a issue. I have done this kind of thing before and never ran across this problem before.

    Thanks,
    Greg

  2. #2
    Join Date
    Nov 2003
    Posts
    6

    Re: Can't add fields to table in EM - Odd SP3a prob?

    Hmm....ok. I have really narrowed it down now. The version that I am running on my server is 8.00.859. The version I have on my development machine is 8.00.760.

    I detached the db from my server, attached it on my box, tried the same thing as above in my first post, and I was able to do it without a problem.

    Anyone else experience this?

    Greg

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •