Results 1 to 3 of 3
  1. #1
    Join Date
    Jul 2003
    Posts
    13

    Unanswered: Connection Problem about (Chinese Character)

    Dear all,

    I got a problem on odbc between Oracle and AS/400 system

    my AS/400 table aaa contains Chinese Characters and I have made a ODBC connection 'test'

    when I type

    select * from aaa@test;

    non chinese character rows can be displayed,

    but chinese rows is selected, the follow message is shown below.

    ORA-28500: ?q ORACLE ?H Oracle ?t?H??s?u?H^?p?U?T??:
    ORA-02063: b line e, PR_HSODBC

    Can anyone help me?

    Thanks alot!

  2. #2
    Join Date
    Nov 2003
    Location
    Bangalore, INDIA
    Posts
    333

    Thumbs up

    Hi,

    connection from ORACLE to a AS/400 system returned this message. This is because it Could not open ODBC Connection . use only hostname.database in the connect descriptor of the initialization file and add the ip address of the hostname to your hosts file instead (if needed).
    SATHISH .

  3. #3
    Join Date
    Jul 2003
    Posts
    13
    Originally posted by satish_ct
    Hi,

    connection from ORACLE to a AS/400 system returned this message. This is because it Could not open ODBC Connection . use only hostname.database in the connect descriptor of the initialization file and add the ip address of the hostname to your hosts file instead (if needed).
    Thanks for your help.

    in fact, i can query the table for all english character fields, but not chinese character.

    for example,
    select bbb from aaa@test;

    1-5000 rows in bbb fields is english character, and 5001 row contains chinese character.

    then i run the sql statment
    1-5000 rows can be displayed and 5001 row or after rows cannot be displayed, the upper error message is displayed.

    Can anyone help me?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •