Results 1 to 6 of 6
  1. #1
    Join Date
    Nov 2003
    Posts
    42

    Unanswered: can not change the default charset????

    want change the default charset from "cp850"to "iso_1",as following:
    >sp_configure "default character set id",1
    >go
    restart the sybase ,
    >sp_default_charset
    >go
    it shows" the default charset cp850"£¬why£¿£¿£¿

  2. #2
    Join Date
    Nov 2003
    Posts
    42

    Re: can not change the default charset????

    Originally posted by shawnlee
    want change the default charset from "cp850"to "iso_1",as following:
    >sp_configure "default character set id",1
    >go
    restart the sybase ,
    >sp_default_charset
    >go
    it shows" the default charset cp850"£¬why£¿£¿£¿
    1 above is the id of "iso_1"

  3. #3
    Join Date
    Feb 2002
    Location
    Willy is on vacation
    Posts
    1,208
    You have to first confirm if iso_1 is available in syscharsets. Otherwise use the charset or sqlloc utility to add iso_1 along with the sort order that you wish to use.

    Then use the sp_configure option to change the default charset.

    Shutdown and restart the Sybase ASE server. If everything is okay, during the recovery it'll rebuild indexes and shutdown the server itself. You have to start it again and this time the new charset will be used.

    If any databases are offline or if there is any corruption the recovery will fail.

    I think the trouble shooting guide outlines some more steps.

  4. #4
    Join Date
    Nov 2002
    Location
    Switzerland
    Posts
    524
    Use sqlloc on Unix, or syconfig on NT

    Then execute, in each database, a sp_indsuspect.
    For each returned line, fix the problem recreating the index...

    Good luck

  5. #5
    Join Date
    Nov 2003
    Posts
    42
    i am exhausted,but it's defaut charset still is 'cp850',how can i change it to 'iso_1',

  6. #6
    Join Date
    Nov 2002
    Location
    Switzerland
    Posts
    524
    Originally posted by shawnlee
    i am exhausted,but it's defaut charset still is 'cp850',how can i change it to 'iso_1',
    so you are probably on Windows. Use Syconfig to change your sort order

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •