Results 1 to 5 of 5

Thread: ltm issue

  1. #1
    Join Date
    Jan 2003
    Posts
    21

    Unanswered: ltm issue

    Has anyone ever seen this happen:
    1.Syslogs doesn't shrink after dumping the transaction log.
    2.Dropped warmstandby and reset trucation point with
    use database
    go
    dbcc settrunc(ltm, ignore)
    go
    )
    3.Then to verify the status of ltm as '0'
    use database
    go
    dbcc gettrunc
    go
    )
    4. but the status of ltm still shows as '1' and the only way to clear this was to stop and start the server service (win2k enterprise server box)

    Any clues or ideas why? We have talked to sybase and they don't know.

    thanks,
    Ova

  2. #2
    Join Date
    Dec 2003
    Location
    Belgium
    Posts
    19

    Re: ltm issue

    Originally posted by Ova
    Has anyone ever seen this happen:
    1.Syslogs doesn't shrink after dumping the transaction log.
    2.Dropped warmstandby and reset trucation point with
    use database
    go
    dbcc settrunc(ltm, ignore)
    go
    )
    3.Then to verify the status of ltm as '0'
    use database
    go
    dbcc gettrunc
    go
    )
    4. but the status of ltm still shows as '1' and the only way to clear this was to stop and start the server service (win2k enterprise server box)

    Any clues or ideas why? We have talked to sybase and they don't know.

    thanks,
    Ova
    To remove all syslog pointers you can disable the replication_agent, this will remove the secondary replication marker

    sp_config_rep_agent mydb, 'disable'
    go

    This will work in replication server 11.5 and higher on ASE

    hope this helps,

    Toon Eysakkers
    Babam Bites

  3. #3
    Join Date
    Jun 2002
    Location
    Argentina
    Posts
    78
    Try this:


    USE <DB>
    go

    sp_stop_rep_agent <DB>
    go

    dbcc gettrunc
    go

    dbcc settrunc('ltm', 'ignore')
    go

    DUMP TRANSACTION <DB> WITH TRUNCATE_ONLY
    go


    I think you just need "sp_stop_rep_agent" before disable the trunction point (you dont need disble the rep agent).
    Of courses you will have to reconfigurate the warnstandby for this <DB> (That mean move a new backup to the replicate db, ...etc ).
    To start again the replication agent for this <DB>:

    USE RSSD
    go

    rs_zeroltm <SERVER>, <DB>
    go

    Locater has been reset to zero.

    USE master
    go

    USE <DB>
    go

    sp_start_rep_agent <DB>, recovery
    go


    See in the "Replication Server Troubleshooting Guide", "Truncating an Adaptive Server Log" for help.
    Bye Bye

    Sebastian

  4. #4
    Join Date
    Dec 2003
    Location
    Belgium
    Posts
    19
    Don't you need to issue the following command in the database as well

    dbcc settrunc (ltm,valid)
    go

    Or is rs_zeroltm sufficient ?
    best regards,

    Toon Eysakkers

  5. #5
    Join Date
    Jun 2002
    Location
    Argentina
    Posts
    78
    "rs_zeroltm" reset the information into the RSSD databases, but do nothing with the rep_agent (I need do this because I dump the tran log, and there is nothing in the original point and the rep agent use this information to start to replicate).
    I guess that when I start the rep_agent again the truncation point become enable, but may be is a good idea check if the trucnation point is enable with "dbcc gettrunc", and if not then execute the "dbcc settrunc".
    But I think you use "dbcc settrunc('ltm', 'valid')" after you execute "sp_config_rep_agent" (for example a new databases).
    I was sometimes in trouble with log full, and all this script help me without problems.
    When you start the rep agent "with recovery", sometimes you need restart with the normal "sp_start_rep_agent <db>".

    Bye Bye

    Sebastian Velasco

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •