Results 1 to 2 of 2
  1. #1
    Join Date
    May 2003
    Location
    Dallas
    Posts
    817
    Provided Answers: 5

    Unanswered: LinkmasterFields and Access versioning issues

    Hello all! i have been on vacation of sorts.
    Strange issue here

    i have a subform , with linked master and child fields to the parent form.
    On the subform I have a combo box with an after update event. On win98 machines using Access2000 I get all the expected behavior one would expect with the linked fields and the afterupdate event. However, when placing the app on a win2000 machine using AccessXp (the db is still in 2000 format) everytime I select an item from the list the following error occurrs:
    The linkmasterfields property has produced this error: 'The object doesn't contain the Automation object 'Treatment Plans'"

    Then my after update code runs appropriately, and I can even go back to that combobox and select a diifferent item with no furhter message. This only happens on the win2000 and Accessxp machines.

    Any versioning or OS issues with linkmasterfields out there?

  2. #2
    Join Date
    May 2003
    Location
    Dallas
    Posts
    817
    Provided Answers: 5

    Re: LinkmasterFields and Access versioning issues

    Issue resolved - there are registry issues between accessxp and 2000. In order to eliminate the error - one has to only identify the control(field) in the linkmaster property instead of the complete literal
    for instance
    myid instead of mytable.myid



    Originally posted by axsprog
    Hello all! i have been on vacation of sorts.
    Strange issue here

    i have a subform , with linked master and child fields to the parent form.
    On the subform I have a combo box with an after update event. On win98 machines using Access2000 I get all the expected behavior one would expect with the linked fields and the afterupdate event. However, when placing the app on a win2000 machine using AccessXp (the db is still in 2000 format) everytime I select an item from the list the following error occurrs:
    The linkmasterfields property has produced this error: 'The object doesn't contain the Automation object 'Treatment Plans'"

    Then my after update code runs appropriately, and I can even go back to that combobox and select a diifferent item with no furhter message. This only happens on the win2000 and Accessxp machines.

    Any versioning or OS issues with linkmasterfields out there?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •