I was trying to install the Crypt::Blowfish module and I got this error.

C:\>ppm install http://theoryx5.uwinnipeg.ca/ppms/Crypt-Blowfish.ppd
Installing package 'http://theoryx5.uwinnipeg.ca/ppms/Crypt-Blowfish.ppd'...
Error installing package 'http://theoryx5.uwinnipeg.ca/ppms/Crypt-Blowfish.ppd':
Read a PPD for 'http://theoryx5.uwinnipeg.ca/ppms/Crypt-Blowfish.ppd', but it i
s not intended for this build of Perl (MSWin32-x86-multi-thread)

Any Ideas Of What Built Of Perl I need?