Results 1 to 3 of 3
  1. #1
    Join Date
    Dec 2003
    Posts
    1

    Red face Unanswered: cannot create database

    I've installed Oracle 8.1.6 on Redhat 7.2 with all the steps to be taken, including removing the "-z" line in the genclntsh. But when I tried to create the database either using DBCA or running the creation script manually, it fails. I get the following reply

    SQL> connect internal
    Connected to an idle instance.
    SQL> startup nomount pfile=/users1/oracle/8i/u01/app/oracle/admin/pfile/initproddb.ora
    ORA-24323: value not allowed
    ORA-24323: value not allowed
    ORA-03113: end-of-file on communication channel
    SQL>

    The contents of the initproddb.ora is as follows:
    *********************************
    db_name = "proddb"
    db_domain = world

    instance_name = proddb

    service_names = proddb.world


    control_files = ("/users2/oracle/oradata/limitsys/control01.ctl", "/users2/oracl
    e/oradata/control02.ctl", "/users2/oracle/oradata/control03.ct
    l")

    open_cursors = 100
    max_enabled_roles = 30
    db_block_buffers = 2048

    shared_pool_size = 52428800
    large_pool_size = 20971520
    java_pool_size = 20971520

    log_checkpoint_interval = 10000
    log_checkpoint_timeout = 1800

    processes = 50

    log_buffer = 163840

    background_dump_dest = /users1/oracle/8i/u01/app/oracle/admin/bdump
    core_dump_dest = /users1/oracle/8i/u01/app/oracle/admin/cdump
    user_dump_dest = /users1/oracle/8i/u01/app/oracle/admin/udump

    db_block_size = 8192

    remote_login_passwordfile = exclusive

    os_authent_prefix = ""
    job_queue_processes = 4
    job_queue_interval = 60
    distributed_transactions = 10
    open_links = 4
    mts_dispatchers = "(PROTOCOL=TCP)(PRE=oracle.aurora.server.SGiopServ er)"
    mts_dispatchers = "(protocol=TCP)"

    compatible = "8.1.0"
    sort_area_size = 65536
    sort_area_retained_size = 65536
    ******************************
    I've also followed the recommended shared memory from this forum:
    ****************************
    kernel.shmmax=1073741824
    kernel.shmmni=4096
    kernel.shmall=2097152
    kernel.sem=250 32000 100 128
    fs.file-max=65536
    net.ipv4.ip_local_port_range=1024 65000
    ************************************
    Does anyone has any idea how I can proceed from here? Thanks in advance..

  2. #2
    Join Date
    Jul 2003
    Posts
    2,296
    could it be possible that you are using a parameter that is not compliant with 8.*?

    I cannot detect where you are going wrong right off the bat however.

    researching the error shows:
    Code:
    ORA-24323 value not allowed
    
    Cause: A null or invalid value was passed in for a mandatory parameter.
    
    Action: Verify that all mandatory parameters are properly initialized.
    this would indicate you are not intializing a parameter properly.

    I would try these edits:
    add:
    sessions=50
    - The_Duck
    you can lead someone to something but they will never learn anything ...

  3. #3
    Join Date
    Sep 2003
    Location
    Washington, DC
    Posts
    13
    I found an Oracle note relating to this problem:

    Doc ID: Note:1019649.102
    Subject: ORA-24323 ORA-03113 ON STARTUP
    Type: PROBLEM
    Status: PUBLISHED
    Content Type: TEXT/PLAIN
    Creation Date: 09-NOV-1999
    Last Revision Date: 06-AUG-2003

    Problem Description -------------------
    You have changed an init.ora parameter that affects the size of the SGA, for example, DB_BLOCK_BUFFERS. Now, when you attempt to startup from sqlplus, you receive the following errors:

    ORA-24323: value not allowed

    Cause: A null value or a bogus value was passed in for a mandatory parameter.

    Action: Verify that all mandatory parameters are properly initialized.

    ORA-03113: end-of-file on communication channel

    Cause: An unexpected end-of-file was processed on the communication channel. The problem could not be handled by the SQL*Net, two task, software.

    Action: If this message occurs during a connection attempt, check the setup files for the appropriate SQL*net driver and confirm SQL*Net software is correctly installed on the server. Attempting to startup from svrmgr gives the ORA-03113 error.

    Solution Description --------------------
    Use ulimit or limit to examine the values for the various kernel parameters that affect physical memory. Use ulimit for Ksh (Korn shell). Use limit for Csh (Cshell). Type: ulimit -a to see what your parameters are set to. For example: [rtcdec3]/u02/home/usupport> ulimit -a time(seconds) unlimited file(blocks) unlimited data(kbytes) 2097152 stack(kbytes) 2048 memory(kbytes) 2049720 coredump(blocks) unlimited nofiles(descriptors) 4096 vmemory(kbytes) 2097152 Make sure memory and virtual memory are large enough to accommodate the changes you have made to your SGA. If they are no, change them using the ulimit (or limit) command. For example: ulimit -v <value> Would change the value of the virtual memory parameter. You can use the man command to find out more about the ulimit command.

    Explanation ----------- You are attempting to create an SGA that is larger than the physical memory of your machine. It may be possible to change kernel parameters to allocate more physical memory. One of the kernel parameters is not large enough for the newly sized SGA. Increasing the kernel parameter may solve the problem.

    References ----------
    [NOTE:69480.1] Tru64 UNIX: Help with SGAs Larger than 2Gb [NOTE:1883.1] ORACLE AND THE OPERATING SYSTEM FILE SIZE LIMIT
    [NOTE:1016425.102] ORA-24323 ORA-3113 UNABLE TO START DATABASE AFTER INCREASING SHARED POOL

    Search Words ------------ svrmgrl SQL*Plus ORA-3113
    --------------------------------------------------------------------------------

    Copyright (c) 1995,2000 Oracle Corporation. All Rights Reserved. Legal Notices and Terms of Use.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •