Results 1 to 4 of 4

Thread: export error

  1. #1
    Join Date
    Mar 2002
    Posts
    162

    Unanswered: export error

    I am getting this error during an export

    "ORA-04031: unable to allocate 4032 bytes of shared memory ("large pool","unknown
    object","joxu heap init","ioc_allocate_pal")"

    I naturally increased my shared pool and also my large pool but I still get the error

    I am doing a user/schema level export. The error occurs right after its done exporting tables and wants to export synonyms

    I just tried increasing the shared_pool_reserved_size....we'll see what happens.

    Is there anything I'm missing

  2. #2
    Join Date
    Jul 2003
    Posts
    2,296
    what is your buffer parameter set to?
    - The_Duck
    you can lead someone to something but they will never learn anything ...

  3. #3
    Join Date
    Mar 2002
    Posts
    162
    db_block_size = 4096

    db_block_buffers = 35663

    shared_pool_size = 65000000
    shared_pool_reserved_size = 100000

    large_pool_size = 50000000
    java_pool_size = 10000000 (just increased from 4500000)


    I just read on meta link that there was a bug with my version of Oracle (8.1.7.0.0) and that the error really points to a small java_pool_size..i quote "Oracle had suggested that the 04031's reference to the shared pool was misleading" I hope it works

  4. #4
    Join Date
    Mar 2002
    Posts
    162
    It worked. It was the Java pool Size. Thanks for your help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •