Results 1 to 3 of 3
  1. #1
    Join Date
    Dec 2003
    Posts
    2

    Unanswered: SQL30081N Communication error when catalog Linux DB2 Instance on the remote Windows c

    Hi, there,

    I am runing DB2 UDB V7.2 server on Redhat Linux 7.3 and Client on Window XP, FixPack 7.
    When I attempt to catalog the Linux DB2 instance using a remote Windows
    Client, it cannot detect any new instance. I typed in the instance name
    manually and then I got the following error message:

    Unable to detect nodetype for instance - "db2inst1 (DB2M)". Reason Code:
    "-1".

    At this step, the catalog of the instance was somehow created.
    Then I cataloged the databases, and I got the following error when I tried
    to connect to the database (click on the name of the database in the Control
    Center)

    [IBM][CLI Driver] SQL30081N A communication error has been detected.
    Communication protocol being used: "TCP/IP". Communication API being used:
    "SOCKETS". Location where the error was detected: "". Communication
    function detecting the error: "connect". Protocol specific error code(s):
    "10061", "*", "*". SQLSTATE=08001


    I searched old posts and did the following configuration:

    1. add two lines to the /etc/services:

    db2cdb2inst1 50000/tcp # Connection port for DB2 instance db2inst1
    db2idb2inst1 50001/tcp # Interrupt port for DB2 instance db2inst1

    2. update dbm service name
    db2 upate dbm cfg using svcename db2cdb2inst1

    then I retarted the computer. However, I did not get rid of the problem.
    Could anyone give me some hint?
    Thanks a lot in advance.

    JZ

  2. #2
    Join Date
    Jul 2003
    Location
    Austin, TX, USA
    Posts
    278

    DB2COMM Parameter

    Hi,

    This error occurs when the communication parameter is not properly set at the instance level.

    Please check for the value of the DB2COMM parameter at DBM Level, this will let you know what is the protocol that the instance is configured for. If not you would have to update the same.

    db2 set db2comm=tcpip

    Also set the parmeter DB2_ENABLE_LDAP=no

    HTH

    Nitin

  3. #3
    Join Date
    Dec 2003
    Posts
    2
    Thanks very much, Nitin. It works now by following your advice.
    Juyuan

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •