Results 1 to 13 of 13
  1. #1
    Join Date
    Nov 2003
    Location
    Mars
    Posts
    115

    Unanswered: unable to kill session

    Hi,

    We have locked session, and trying to kill using command kill <spid> in query analyzer, but the session is not getting killed.
    when we right click and c the properties of the spid it says sp_execute.
    pls help us in killing this.

    Regards,
    TIA
    Adil

  2. #2
    Join Date
    Feb 2002
    Posts
    2,232
    Did you refresh the Current Activity ?

  3. #3
    Join Date
    Nov 2003
    Location
    Mars
    Posts
    115
    yes i did

  4. #4
    Join Date
    Feb 2002
    Posts
    2,232
    Have you contacted the user to terminate the application on their machine and/or reboot their machine ? What do you mean by locked - is it hung executing a stored procedure ?

  5. #5
    Join Date
    Nov 2003
    Location
    Mars
    Posts
    115
    two process are trying to use the same data
    iam trying to kill the user's session.
    but the command is not working.

  6. #6
    Join Date
    Feb 2002
    Posts
    2,232
    I would try to kill either session. If that does not work then kill the application in the clients machine or reboot. If that does not work then restart sql server.

  7. #7
    Join Date
    Nov 2003
    Location
    Mars
    Posts
    115
    i cant do that as it is remotely accessed and the clients will not permit to do that.
    i have any how to kill the locked process.

  8. #8
    Join Date
    Feb 2002
    Posts
    2,232
    What is the status of the spid you killed ? You can use the with statusonly option. It may be in the process of terminating.

  9. #9
    Join Date
    Feb 2002
    Posts
    2,232
    Also, what is the status and command for that spid ?

  10. #10
    Join Date
    Nov 2003
    Location
    Mars
    Posts
    115
    status is sleeping and command is select
    pls help us in this.

    waiting for ur reply

  11. #11
    Join Date
    Feb 2002
    Posts
    2,232
    What is the spid number and what was returned when you ran 'kill spid with statusonly' ?

  12. #12
    Join Date
    Nov 2003
    Location
    Mars
    Posts
    115
    hi,

    when i give command kill 144 with statusonly its giving me error
    i am onsqlsever 7. and also there is an db optimization job which is hanging.
    pls help us
    TIA

  13. #13
    Join Date
    Feb 2002
    Posts
    2,232
    Is the problem with the optimization ? If so, do a dbcc checktable/checkdb to see if there is corruption. If it is an index issue, you can run dbcc dbreindex or drop/recreate the indexes. Do you know where the problem exists within the optimization ?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •