Page 1 of 2 12 LastLast
Results 1 to 15 of 20
  1. #1
    Join Date
    Dec 2003
    Posts
    11

    Unhappy Unanswered: SQL Server installation problem...

    I have a laptop running Windows XP Pro. Is it possible
    to load SQL Server 2000 (Personal or Developer) when
    Office 2003 Business Contact Manager is installed
    (another instance of SQL Server)? BCM was already
    installed when I got the laptop and seems to interfere with the new installation. Currently, whenever I install SQL Server I get "SuperSocket Info: Bind failed on TCP port 1433". If I change the port I'll get the same error with the new port number. There is a tech note for this error but the fix (using managing cluster
    functionality) seems to require the Enterprise edition
    which doesn't run on XP Pro. Is there any other
    workaround for this or do I have to uninstall BCM. Has
    anyone else had this problem? Any help would be greatly
    appreciated...

  2. #2
    Join Date
    Feb 2002
    Posts
    2,232
    Did you read this article:

    article

  3. #3
    Join Date
    Dec 2003
    Posts
    11
    Originally posted by rnealejr
    Did you read this article:

    article
    Thanks for the prompt reply. I did not see that TechNote (although I did try some of the others referenced). What I did notice when I tried installing is that SQL Server did bind the port but it was the SQL Server instance having to do with the Business Contact Management and not the standalone SQL Server instance. Should I make the BCM instance dependent on the regular SQL Server service?

  4. #4
    Join Date
    Feb 2002
    Posts
    2,232
    Is the database used by bcm msde or sql server ?

  5. #5
    Join Date
    Dec 2003
    Posts
    11
    Originally posted by rnealejr
    Is the database used by bcm msde or sql server ?
    BCM uses SQL Server (although it is just the engine and not a complete install).

  6. #6
    Join Date
    Feb 2002
    Posts
    2,232
    This sounds like msde... Try upgrading the msde to your sql server version.

  7. #7
    Join Date
    Dec 2003
    Posts
    11
    Originally posted by rnealejr
    This sounds like msde... Try upgrading the msde to your sql server version.
    "Business Contact Manager" sets up its own SQL Server named instance (named "MICROSOFTBCM") instead of using the Default instance. There seems to be no way to override this behavior.

    Is this something that can be upgraded?

  8. #8
    Join Date
    Feb 2002
    Posts
    2,232
    Just to verify - you modified the tcp/ip port using the sql server network utility ? Which instance did you modify ?

  9. #9
    Join Date
    Dec 2003
    Posts
    11
    Originally posted by rnealejr
    Just to verify - you modified the tcp/ip port using the sql server network utility ? Which instance did you modify ?
    I changed the TCP port by changing the port when SQL Server installed (so I'm guessing that would be the default instance). The problem was no matter what I changed it to it would still throw the error.

  10. #10
    Join Date
    Feb 2002
    Posts
    2,232
    Use the SQL Server Network Utility to make these changes.

  11. #11
    Join Date
    Dec 2003
    Posts
    11
    Originally posted by rnealejr
    Use the SQL Server Network Utility to make these changes.
    Great! Thanks for your help. I'll try it tomorrow and let you know how it works as I don't have the SQL Server discs on me today.

  12. #12
    Join Date
    Dec 2003
    Posts
    11
    Originally posted by Eck
    Great! Thanks for your help. I'll try it tomorrow and let you know how it works as I don't have the SQL Server discs on me today.
    I tried setting the port for the MICROSOFTBCM named instance in the Server Network Utility but it doesn't take. It boots up and ignores the new settings and continues to have the original problem "SuperSocket Info: Bind failed on TCP port 1433." If you then look at the network utility it shows it should be running on the new port. If you use fport to see what ports are bound to what it shows it is not bound to the new port.

  13. #13
    Join Date
    Feb 2002
    Posts
    2,232
    What happens if you change the default instance port ?

  14. #14
    Join Date
    Dec 2003
    Posts
    11
    Originally posted by rnealejr
    What happens if you change the default instance port ?
    I got around the changing the TCP port of the named instance 'MICROSOFTBCM' by reinstalling SP3a. However it gives the same 'SuperSocket Info: Bind failed on TCP port 1433". If I change the default instance it gives the same error with the new port number.

    But fport does show SQL Server binding the given TCP Port. But one strange thing is that for BCM fport shows it being bound by 'C:\Program Files\Microsoft SQL Server\MSSQL$MICROSOFTBCM\Binn\sqlservr.exe'. For the default instance, it is 'C:\PROGRA~1\MI6841~1\MSSQL\binn\sqlservr.exe'. When I went to see what MI6841* was it wound up being the Microsoft SQL Server directory. Almost like a UNIX linked directory. Seems bizarre to me

  15. #15
    Join Date
    Feb 2002
    Posts
    2,232
    When you installed sql server - did you select it to be the default instance ? When you installed sql server after bcm, did you stop the bcm sql server services ? I would try to reinstall with it disabled and specifying it as a default instance. If that does not work, uninstall both and install sql server followed by bcm.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •