New SQL database. Existing Access97 app connects to the SQL db via a dsnless connection using NT authentication. Application resides on client.

There are approx 15 users in the app. The backend data is about a gig. The application is code heavy. Almost all the processes are ADO direct calls. The command and connection timeout are both set at 5000.

Great performance for the first 4 days. Last Tuesday the performance started to slow and from then to now we are alternating between acceptable although not great preformance to a crawl speed (7-10 minutes!). I have done the following:

1.) reinstalled MDAC
2.) reinstalled Access
3.) compacted and repaired the front end app
4.) rebuilt the indexes on SQL
5.) had a trace put on to see if there are any locking issues (there are not)
6.) had a network sniffer put on to determine bandwidth utilization. 25% utilization no packets being dropped.
7.) checked utilization on the server (10% utilization most of the time)
8.) ruled out any type of SMS issue (one of the errors pointed me in this direction)

Some of the errors we have received have been:

* login failed for user [null]: not a trusted sql connection. (this is after they have logged in and recordsets/data has been returned from the server.)

* DBNETLIB connection read. recv(). General network error check your network documentation.

* timeout expired and then under that is the following "general network error: check your network documentation"

Can anyone help? If you have any ideas on anything to do with the SQL server or network please let me know what I should say to the DBA and the network contact.

Thank you!!!!