Results 1 to 10 of 10
  1. #1
    Join Date
    Dec 2003
    Posts
    4

    Unanswered: Mystery Text Box

    I had a text box on a report with the control source set to a combo box on my main form. I decided to go in a different direction with the report data and no longer needed this text box.

    I decided to delete this text box and replace it with an unbound text box that has an IIF statement for a control source.

    Now, when I run the report it keeps prompting me for a value for the deleted text box. The report runs fine, but it keeps asking for a value for that text box that does not exist anymore.

    Anyone know what the %$#@ might be going on here?

  2. #2
    Join Date
    Sep 2003
    Posts
    83

    Re: Mystery Text Box

    Originally posted by jastek
    I had a text box on a report with the control source set to a combo box on my main form. I decided to go in a different direction with the report data and no longer needed this text box.

    I decided to delete this text box and replace it with an unbound text box that has an IIF statement for a control source.

    Now, when I run the report it keeps prompting me for a value for the deleted text box. The report runs fine, but it keeps asking for a value for that text box that does not exist anymore.

    Anyone know what the %$#@ might be going on here?

    Did you check the report design, make sure the textbox is not there in the report. Also checks the groups in the report.

  3. #3
    Join Date
    Dec 2003
    Posts
    4

    Question

    Yes. I checked everywhere on the report and in all groups. I also used the object drop down list in the upper left corner to see if the text box was listed and it was not.

  4. #4
    Join Date
    Nov 2003
    Posts
    40
    It is probably still in your query that you are pulling from. Bring up the query that you use to populate your report, and see if it is still there.

  5. #5
    Join Date
    Dec 2003
    Posts
    4
    I checked the query and the code behind the report. There is no reference to the field.

    I have worked around the problem by creating a new report and did a copy/paste of all the fields. The report works now, however, I am still curious as to what happened.

  6. #6
    Join Date
    Sep 2003
    Location
    Caldes de Malavella, Spain
    Posts
    244
    Shit happened.
    Andy Briggs
    Elmhurst Solutions Limited
    Database Development and Consultancy
    http://www.elmhurstsolutions.com

  7. #7
    Join Date
    Nov 2003
    Posts
    40
    First of all, how incredibly rude to post a response like that.


    _____

    Jastek,

    I am glad that you solved your problem even if we couldn't figure out the cause of the original problem.

  8. #8
    Join Date
    Sep 2003
    Location
    T.O.
    Posts
    326
    If you still care about what happened, *how* did access ask you for a value? Providing an error message? Looking for an input?
    All code ADO/ADOX unless otherwise specified.
    Mike.

  9. #9
    Join Date
    Dec 2003
    Posts
    4
    When I ran the report I got the "Enter Parameter" pop up window. The parameter it was looking for was the value of the deleted text box, which calculated a column sum.

    Before the text box was deleted, the report did not give me the "Enter Parameter" pop up window.

    Only after I deleted the text box did it , start with the "Enter Parameter" pop up window.
    Last edited by jastek; 12-18-03 at 14:28.

  10. #10
    Join Date
    Sep 2003
    Location
    T.O.
    Posts
    326
    Unless something else on the report was depending on that textbox, it appears to be a standard corruption issue. Because you were able to copy all the controls to a new report and have it work, I'm going with the latter.

    Access sometimes 'forgets' stuff. I notice this most when I write an query, filter on some data, save the query, then re-run. It looks for Query1.Value where Value is whatever I filtered on.
    All code ADO/ADOX unless otherwise specified.
    Mike.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •