Results 1 to 7 of 7
  1. #1
    Join Date
    Oct 2003
    Posts
    83

    Question Unanswered: Restrict Warning Message

    I used a temporary table in a stored procedure.Whenever this stored procedure is executed with the desired output it is giving the warning message-
    Warning: The table '#TEMPTBLPERSON' has been created but its maximum row size (10930) exceeds the maximum number of bytes per row (8060). INSERT or UPDATE of a row in this table will fail if the resulting row length exceeds 8060 bytes.

    Now my question is how can I avoid of displaying this warning message
    in the stored procedure without altering the temporary table ?

  2. #2
    Join Date
    Jul 2003
    Location
    The Dark Planet
    Posts
    1,401

    Re: Restrict Warning Message

    Originally posted by subhasishray
    I used a temporary table in a stored procedure.Whenever this stored procedure is executed with the desired output it is giving the warning message-
    Warning: The table '#TEMPTBLPERSON' has been created but its maximum row size (10930) exceeds the maximum number of bytes per row (8060). INSERT or UPDATE of a row in this table will fail if the resulting row length exceeds 8060 bytes.

    Now my question is how can I avoid of displaying this warning message
    in the stored procedure without altering the temporary table ?
    The best way is to reduce the data size of the table to less than 8060 bytes.

    other way .. i believe might be to set the option

    set ansi_warnings off
    Get yourself a copy of the The Holy Book

    order has no physical Brett in The meaning of a Kaiser . -database data

  3. #3
    Join Date
    Oct 2003
    Posts
    83
    I wrote clearly I don't want to reduce the length of the table.
    set ansi_warnings_off|on is not giving desired output.
    Subhasish

  4. #4
    Join Date
    Jul 2003
    Location
    The Dark Planet
    Posts
    1,401
    Originally posted by subhasishray
    I wrote clearly I don't want to reduce the length of the table.
    set ansi_warnings_off|on is not giving desired output.
    Subhasish
    Clearly ... you are not paying heed to the warning message .. An insert into your table will fail in case the data is more than 8060 bytes . You should take that case into consideration.

    Am searching for the other answer .. will get back as soon as i find it
    Get yourself a copy of the The Holy Book

    order has no physical Brett in The meaning of a Kaiser . -database data

  5. #5
    Join Date
    Jul 2003
    Location
    San Antonio, TX
    Posts
    3,662
    There is no "other" answer, you've said it all. the only other thing to do would be to split the table into 2 with 1-to-1 relationship.

  6. #6
    Join Date
    Jul 2003
    Location
    The Dark Planet
    Posts
    1,401
    I was searching for a server property where i could control the severity level of warnings and errors as is availible in osql with the -m flag.
    Get yourself a copy of the The Holy Book

    order has no physical Brett in The meaning of a Kaiser . -database data

  7. #7
    Join Date
    Nov 2002
    Location
    Jersey
    Posts
    10,322
    Originally posted by subhasishray
    I wrote clearly I don't want to reduce the length of the table.
    set ansi_warnings_off|on is not giving desired output.
    Subhasish
    Whether you know it or not...that comes across with some attitude..

    If you can't be flexible...then I don't know who will...

    good luck...
    Brett
    8-)

    It's a Great Day for America everybody!

    dbforums Yak CorralRadio 'Rita
    dbForums Member List
    I'm Good Once as I ever was

    The physical order of data in a database has no meaning.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •