Results 1 to 6 of 6
  1. #1
    Join Date
    Oct 2002
    Posts
    88

    Unanswered: sorting in a eeport

    I have a report that I want to do some grouping and sorting on. I used the group and sort button, selected the fields I want but find that the last item, which is a date is not sorting ascending as I set it for.

    I have had this or something similar happen in the past and was told to add another sort/group item and it took care of the problem but I don't recall exactly what I had to do.

    Thanks in advance for any help

  2. #2
    Join Date
    Mar 2003
    Location
    The Bottom of The Barrel
    Posts
    6,102
    Provided Answers: 1

    Re: sorting in a eeport

    Originally posted by tmort
    I have a report that I want to do some grouping and sorting on. I used the group and sort button, selected the fields I want but find that the last item, which is a date is not sorting ascending as I set it for.

    I have had this or something similar happen in the past and was told to add another sort/group item and it took care of the problem but I don't recall exactly what I had to do.

    Thanks in advance for any help
    You're already on the right track. Essentially you add a another grouping level to the report, set it's hieght to zero and no header/footer. This simply allows you to set another sorting level without restricting the iteration of your detail. Simply add another grouping level to the end of the "group and sort" menu you already mentioned, set it to your date field, and leave everything else blank. That should work out fine for you.

  3. #3
    Join Date
    Oct 2002
    Posts
    88
    I did that and that didn't help. I've attached a sample db (the attachement doesn't have the added group, but I did it and it didn't work)
    Attached Files Attached Files

  4. #4
    Join Date
    Mar 2003
    Location
    The Bottom of The Barrel
    Posts
    6,102
    Provided Answers: 1
    Originally posted by tmort
    I did that and that didn't help. I've attached a sample db (the attachement doesn't have the added group, but I did it and it didn't work)
    The problem is your query returns null for the analysis date. Running the query by itself reveals that there is no data to sort on, hence you are not getting the results you were looking for. Analysis date is also empty in the underlying table.

  5. #5
    Join Date
    Oct 2002
    Posts
    88
    Thanks,

    I feel stupid, I was using analysis date for the field not collection date.

    Thanks again

  6. #6
    Join Date
    Mar 2003
    Location
    The Bottom of The Barrel
    Posts
    6,102
    Provided Answers: 1
    Originally posted by tmort
    Thanks,

    I feel stupid, I was using analysis date for the field not collection date.

    Thanks again
    No problem, I'm glad it was something simple. I like it when it's simple.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •