Results 1 to 3 of 3
  1. #1
    Join Date
    Dec 2003
    Location
    Trivandrum
    Posts
    27

    Unanswered: Unable to contact DB2 through Client Machine

    Hi

    I'm on the process of installing Content Manager on one of the W2k Server with SP 4. The installation includes

    1. DB2 v8.1 with Fix Pack2
    2. WebSphere Application Server 5.02
    3. Content Manager v8.2

    The installation is successful and I loaded Content Manager Client on the server and also another Client Machine.

    The client Machine has the following

    1. DB2 Runtime Client v8.1
    2. Content Manger Client for Windows 8.2

    My problem:

    When I try to connect the CM by using CM client, it is working properly on the Server machine but not working from another machine and it says the error like following:

    *************************
    [IBM][CLI Driver] SQL30081N A communication error has been detected. Communication protocol being used: "TCP/IP". Communication API being used: "SOCKETS". Location where the error was detected: "". Communication function detecting the error: "connect". Protocol specific error code(s): "10061", "*", "*". SQLSTATE=08001
    [SQLDriverConnect] [SQLCODE=- 30081,SQLSTATE=08001][SERVER=ICMNLSDB:USERID=icmco
    nct] (STATE) : 08001
    **************************

    Can somebody help me on this issue please

  2. #2
    Join Date
    Jul 2003
    Location
    Austin, TX, USA
    Posts
    278

    Communication Setup.

    Hi,

    This usually occurs when the instance is not updated for the communication protocol parameter.

    Please check the value of your DB2COMM parameter at the instance level. That should be set to the protocol that your environment uses.

    set the DB2COMM parameter to TCPIP and I am sure that would ideally resoive your problem.

    HTH

    Nitin.
    HTH

    Nitin

    Ask the experienced rather than the learned

  3. #3
    Join Date
    Dec 2003
    Location
    Trivandrum
    Posts
    27

    Smile Re: Communication Setup.

    Hi Nitin

    Thanks for the update.

    I updated the following Configuration file entries

    DB2COMM=TCPIP and
    TCP/IP Service Name = DB2_DB2

    It is working fine now.

    Thank you once again for your prompt reply.

    Chandra.

    Originally posted by nitingm
    Hi,

    This usually occurs when the instance is not updated for the communication protocol parameter.

    Please check the value of your DB2COMM parameter at the instance level. That should be set to the protocol that your environment uses.

    set the DB2COMM parameter to TCPIP and I am sure that would ideally resoive your problem.

    HTH

    Nitin.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •