Results 1 to 9 of 9
  1. #1
    Join Date
    Dec 2003
    Location
    Charlotte, NC USA
    Posts
    7

    Unanswered: MSDE 2000 SP3a Workgroup Access

    Greetings everyone.

    I work in a retail environment and have an MSDE2000 SP3a server installed in 350+ stores. I need to access the server from another computer in the workgroup (not domain) and I can't. I'm getting "SQL Server does not exist or access denied." The server was installed using the default option of Windows Authentication and I have changed it to Mixed mode authentication on one of my in-house lab systems with no luck. Also, when I try to create and OLEDB connection for the database and drop down the list of servers, there is nothing there (not even the local server.) Sorry but I do not have the error message that I get when that happens but I think when I solve the first problem the second will go away too.

    Thanks for your input

  2. #2
    Join Date
    Dec 2003
    Posts
    15
    Hi,

    Are you saying that when you changed a server to mixed mode you were still unable to connect to it? Even from the local machine?

    In my experience with MSDE, when running in mixed mode you should be able to connect remotely with EM or QA with the UID & PWD.

    Have you confirmed that you are able to connect over 1433/1434 on the network? I guess this is the equivalent of "have you checked your cables" but it's worth checking to make sure.

    Dan

  3. #3
    Join Date
    Dec 2003
    Location
    Charlotte, NC USA
    Posts
    7
    Hi Dan -- thanks for the reply.

    I have always been able to connect to the server, both in Windows Authentication mode and Mixed mode from the local machine on which the server resides. The problem is that I cannot connect in either mode from a different machine in the workgroup. I tried telnet to the local machine using port 1433 and got a connect failed even on the same machine as the server. I did not know about port 1434. I'll try that one when I get back to the office tomorrow.

    Thanks Again

  4. #4
    Join Date
    Feb 2002
    Posts
    2,232
    Use the server network utility.

  5. #5
    Join Date
    Dec 2003
    Location
    Charlotte, NC USA
    Posts
    7
    Not to be dense but what's the "Server Network Utility?"

    I know about osql and can connect to the server while on the local machine but not from another machine.

  6. #6
    Join Date
    Dec 2003
    Posts
    15
    It's one of the utilities installed with SQL. You'll need to run it from the machine you want to connect from. You'll need to set up the connection. You create an alias where you specify the connection properties for the server.

    Dan

  7. #7
    Join Date
    Dec 2003
    Location
    Charlotte, NC USA
    Posts
    7
    Nevermind -- I found it. I dialed into my office computer and ran the server network utility and all protocols were disabled. I won't be able to check the results until Friday but I'm optimistic that this will resolve my problems. Thanks a lot.

  8. #8
    Join Date
    Feb 2002
    Posts
    2,232
    all protocols were disabled
    That will do it.

  9. #9
    Join Date
    Dec 2003
    Location
    Charlotte, NC USA
    Posts
    7
    Once I enabled named pipes and tcp/ip on the server, the workgroup connection works fabulously. Thanks for your help.

    One more question. Is there a registry setting for this that I can download a .reg file to the stores to set this or do I have to manually configure this setting in all my stores? Thanks again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •