Results 1 to 5 of 5
  1. #1
    Join Date
    Dec 2003
    Location
    Essex, UK
    Posts
    12

    Unhappy Unanswered: Using linked pics in DB

    Hi,
    I've got a database which when you've chosen a picture by clicking on the link field, bowsing then selecting, it displays in a picture window.
    The problem I seem to have is it can leave this box on the screen when moving between records too quickly, then without closing down the whole database I can't seem to clear it.
    I don't want to embed the pics as it keeps the size of the database down as it is and I can change a picture without touching the DB.

    Any suggestions on how I can add some code to the next record button so it waits until the picture loads or to just hide the box?
    (It flashes up to show it's loading for each record)

    I've grabbed a screen dump so you can see what I mean.

    Cheers

    Rob
    Attached Thumbnails Attached Thumbnails accessprob1 (small).jpg  

  2. #2
    Join Date
    Feb 2002
    Posts
    403
    I think probably the answer is in your code. It should be in the current event of the form, and should be something like:

    If len(Me.txtPicturePath)>0 then

    Me.imgPic.Picture=me.txtPicturePath

    Else

    Me.imgPic.Picture=vbNullString

    End if

  3. #3
    Join Date
    Dec 2003
    Location
    Essex, UK
    Posts
    12

    Talking

    Thanks for the code, that actually solved the problem of having the picture still showing from the last record you looked at, when you add new one!

    Cheers

    Rob

  4. #4
    Join Date
    Feb 2002
    Posts
    403
    I am sure you could hide the loading box by using API's however, that is probably quite complicated and I don't have code for it. However, I wondered what resolution your images are? If you are scanning them try 72 dpi, you will find the pictures will look the same on screen and the load time will be quicker, so you may avoid the box totally. I only get teh box flashing on screen for high resolution shots.

  5. #5
    Join Date
    Dec 2003
    Location
    Essex, UK
    Posts
    12

    Talking

    Yep, never thought of the obvious!
    Resized all picsto 640x480 and sizes dropped from 200+KB to 20-40KB!
    Now skips through a whole lot quicker!

    Here's the link for any XP users who haven't installed the image resizer yet. Why they didn't include this in XP I don't know!

    http://www.microsoft.com/windowsxp/p.../powertoys.asp

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •