Results 1 to 6 of 6
  1. #1
    Join Date
    Oct 2003
    Location
    Karachi
    Posts
    12

    Question Unanswered: ERROR: ORA-01004: default username feature not supported; logon denied

    Hi guys I m still waiting for the help regarding this problem I've tried all the options that u've mentioned

    Jawed

    Hi all

    I am using Oracle 9i (9.2.0) on Redhat Linux 9.0 and set the parameters as follows:

    1. in init.ora file at {Oracle_home}/dbs folder I set the values as below
    REMOTE_OS_AUTHENT=TRUE
    2. In sqlnet.ora file in {Oracle_home}/network/admin folder the values are at the server side
    NAMES.DEFAULT_DOMAIN = ssuet.edu.pk

    NAMES.DIRECTORY_PATH= (TNSNAMES, ONAMES, HOSTNAME)

    # sqlnet.authentication_services=(NTS)

    # REMOTE_OS_AUTHENT = TRUE

    # SQLNET.AUTHENTICATION_SERVICES=(NTS)

    All I have tried to enable/disable parameters in above mentioned files but change effect when athenticating from client side by supplying username with / and giving the error mentioned in subject line, but when i am logging with sqlplus / from linux telnet session it is working fine. Kindly help me in this regard


    Jawed Iqbal
    Last edited by Jawed; 01-13-04 at 04:13.

  2. #2
    Join Date
    Aug 2003
    Location
    Where the Surf Meets the Turf @Del Mar, CA
    Posts
    7,776
    Provided Answers: 1
    The default for V9.2 is to NOT use initSID.ora file,
    but to use spfileSID.ora file instead.
    Are you REALLY sure Oracle is actually reading the initSID.ora file?
    What OS & OS version is the"client"?

  3. #3
    Join Date
    Sep 2003
    Location
    Virginia, USA
    Posts
    246
    You need remote_os_authent=true. It is false by default. I agree with the other poster that changing it in the init.ora file might have no impact since Oracle uses an spfile by default and ignores the init.ora.

    I think there are many things that can go wrong here, but given your error message I think the other poster put you on the right track.

    For example, in file sqlnet.ora the parameter sqlnet.authentication_services. Right now you have it commented out, which is good since the value you show only works on Windows but you are on Linux. Lookup the correct value for linux, then uncomment the parameter and see what happens.
    MarkRem
    Author, Oracle Database 10g: From Nuts to Soup
    http://www.remidata.com/book_nuts2soup.htm

  4. #4
    Join Date
    Aug 2003
    Posts
    123
    Yes, what the our friends says is true, oracle 9.2 uses spfile by default so any change in the initSID.ora will not be effective, restart the server by mentioning the parameter file as initSID.ora file, it should solve the problem

    To find what init file oracle is using use the following command

    select * from v$parameter where name like 'sp%'

    --jaggu

  5. #5
    Join Date
    Oct 2003
    Location
    Karachi
    Posts
    12
    Originally posted by anacedent
    The default for V9.2 is to NOT use initSID.ora file,
    but to use spfileSID.ora file instead.
    Are you REALLY sure Oracle is actually reading the initSID.ora file?
    What OS & OS version is the"client"?
    I m not sure that what init file is using with oracle but it is working fine on linux using os authentication but giving the mentioned error when authntication from client machine. OS running on client is XP/w2k/nt/w9x what should to set on client side and what to set on server side kindly help me in this regard

  6. #6
    Join Date
    Oct 2003
    Location
    Karachi
    Posts
    12
    Originally posted by markrem
    You need remote_os_authent=true. It is false by default. I agree with the other poster that changing it in the init.ora file might have no impact since Oracle uses an spfile by default and ignores the init.ora.

    I think there are many things that can go wrong here, but given your error message I think the other poster put you on the right track.

    For example, in file sqlnet.ora the parameter sqlnet.authentication_services. Right now you have it commented out, which is good since the value you show only works on Windows but you are on Linux. Lookup the correct value for linux, then uncomment the parameter and see what happens.
    I've tried to set parameter remote_os_athent=true in spfileSID.ora file but no impact. If you know the correct value for linux, plz inform me that i can try 2 solve my problem. Kindly also tell me that which parameters 2 b needed and in which file 2 set.

    JAwed

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •