Results 1 to 2 of 2
  1. #1
    Join Date
    Dec 2003
    Posts
    1

    Unanswered: Help Installing MySQL

    okay.. here is what someone told me to do:

    1.) up2date -d --src mysql

    That will put mysql-3.23.58-1.src.rpm in the /var/spool/up2date/ directory.

    2.)Then build the rpm using this command:

    rpmbuild --rebuild /var/spool/up2date/mysql-3.23.58-1.src.rpm

    That will put mysql-server (and 3 others) in
    the /usr/src/redhat/RPMS/i386/ directory.

    3.)Then just install the mysql-server:

    rpm -Uvh /usr/src/redhat/RPMS/i386/mysql-server-3.23.58-1.i386.rpm



    The last step is where i get hung up. Here is the error message that I get:

    error: Failed dependencies:
    libmysqlclient.so.10 is needed by mysql-server-3.23.58-1
    mysql = 3.23.58 is needed by mysql-server-3.23.58-1
    Suggested resolutions:
    mysql-3.23.58-1.i386.rpm


    then when i go and try to install the mysql-3.23.58-1.i386.rpm i get an error message that says:
    files from install of mysql-3.23.58-1.i386.rpm conflicts with file from package MySQL-server-4.0.17-0



    can someone please tell me what i'm doing wrong... i'n new at this so please explain to me in an easy way..


    Thanks

  2. #2
    Join Date
    Oct 2003
    Location
    Slovakia
    Posts
    482

    Re: Help Installing MySQL

    Originally posted by amateurtalk
    okay.. here is what someone told me to do:

    1.) up2date -d --src mysql

    That will put mysql-3.23.58-1.src.rpm in the /var/spool/up2date/ directory.

    2.)Then build the rpm using this command:

    rpmbuild --rebuild /var/spool/up2date/mysql-3.23.58-1.src.rpm

    That will put mysql-server (and 3 others) in
    the /usr/src/redhat/RPMS/i386/ directory.

    3.)Then just install the mysql-server:

    rpm -Uvh /usr/src/redhat/RPMS/i386/mysql-server-3.23.58-1.i386.rpm



    The last step is where i get hung up. Here is the error message that I get:

    error: Failed dependencies:
    libmysqlclient.so.10 is needed by mysql-server-3.23.58-1
    mysql = 3.23.58 is needed by mysql-server-3.23.58-1
    Suggested resolutions:
    mysql-3.23.58-1.i386.rpm


    then when i go and try to install the mysql-3.23.58-1.i386.rpm i get an error message that says:
    files from install of mysql-3.23.58-1.i386.rpm conflicts with file from package MySQL-server-4.0.17-0



    can someone please tell me what i'm doing wrong... i'n new at this so please explain to me in an easy way..


    Thanks
    At first don't mix the 4.x version with 3.23.x version...
    At second will be better when you download binary version from www.mysql.com and you will be following the steps included in INSTALL file.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •