Results 1 to 2 of 2
  1. #1
    Join Date
    Jan 2004
    Posts
    1

    Unanswered: Clipper XP & Internal error 8002

    I have a client who was succesffulyy running a Clipper application on Novell via DOS. They now want to run the same apllication using a Windows XP machine. However when re-indexing one of the larger files the internal error 8002 occurs. Can you advise me on what setting are required. Exospace is used in building the application.

  2. #2
    Join Date
    Aug 2003
    Location
    West
    Posts
    101

    Re: Clipper XP & Internal error 8002

    I saw this .....

    8002 Indexing error
    While indexing, ordcreate(0) internal error 8002 may appear. It seems to appear mostly with CA-Clipper 5.3 programs linked with ExoSpace and running under Windows 95, although it has also been reported under Windows 3.1, and with CA-Clipper 5.2e and 5.01, and linked with Blinker. Typically, the error occurs on "larger" files (e.g. >10MB or 80,000 records), although that is not always the case.
    It has been reported that the 8002 error occurs unders the German version of CA-Clipper 5.3a during a section of code that opens and closes many tables repeatedly.
    When the error occurs with a Blinker-linked program under Win95, the program terminates with an Windows exception error. With an ExoSpace-linked program the 8002 error appears.
    The ExoSpace link option "EXOSPACE PACKAGE NOVM" disables the VMM system so that when Clipper uses up all available physical memory it will cause either error 8002 or "Conventional memory exhausted". It is not recommended for normal applications, although it may be appropriate for installation programs. Blinker has a similar link option available.
    Internal error 8002 may also be caused by an error in custom C or ASM code which allocates memory and then does not release it properly.
    The Windows memory system may interfere with CA-Clipper's Virtual Memory Manager, causing the error. It is not known whether the problem is limited to the DBFNTX RDD, or occurs in other (all) RDDs.
    Action: Try one or more of the following:
    1) Try increasing the available Virtual Memory to the CA-Clipper programs. Include in the SET CLIPPER environment variable the option:
    //VMSIZE:16834
    For example:
    set CLIPPER=//F:99 //VMSIZE:16834
    Try using different (smaller) values for //VMSIZE. The //F:99 value is just an example - you may have something different.
    2) The program may need more stack space. You can adjust the amount of stack space with the following:
    In RTLINK: add /STACK:sizeBytes
    In BLINKER: add STACK sizeBytes
    The default value of sizeBytes is around 5000. Try increasing it to 8192.
    3) Use the OPTEDIT program with the EXTRAMIN switch. The Option Editor, OPTEDIT.EXE, is a utility that allows you to change the behavior of your CA-Clipper applications which have been linked using ExoSpace.
    EXTRAMIN values of 4096 and 8000 have been reported as successful. To reserve 4MB of memory:
    OPTEDIT appname -EXTRAMIN 4096
    The OPTEDIT program can be found on The Oasis at: http://www.the-oasis.net/files/patch...ror/opt_53.zip
    4) An ExoSpace application can run out of virtual memory if Windows runs out of virtual memory. Try increasing the maximum size of the Windows swap file.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •