Results 1 to 3 of 3
  1. #1
    Join Date
    Jan 2004
    Posts
    1

    Unanswered: userid in formsweb.cfg => ORA-12154

    Hi! I am trying to access a forms server on http://sun2:7778/dev60cgi/f60cgi?config=QQ1, where QQ1 is defined in formsweb.cfg:
    [QQ1]
    serverURL=
    form=login01
    userid=nn1/nn1@qq1
    ...
    'QQ1' is in my tnsnames.ora OK. I can tnsping qq1 successfully, I can sqlplus nn1/nn1@qq1 successfully. But I can't access it from the form.ORA-12154 error. What am I missing...?
    thanks!

  2. #2
    Join Date
    Aug 2003
    Location
    Where the Surf Meets the Turf @Del Mar, CA
    Posts
    7,776
    Provided Answers: 1
    http://metalink.oracle.com/metalink/...&p_id=114085.1
    is the Troubleshooting Guide for the TNS-12154 Error


    First make it work, then make it fancy.
    Can you get the formsweb.cfg section to do anything basic that does NOT involve using tnsnames.ora file? Are you sure the Forms CGI process has the EXACT same environment as you did when you successfully tested using SQL*Plus?

    What OS & OS version?

  3. #3
    Join Date
    Nov 2003
    Location
    Bangalore, INDIA
    Posts
    333

    Thumbs up

    Hi,

    Verify that a TNSNAMES.ORA file exists and is in the proper place and accessible. See the operating system specific manual for details on the required name and location.

    Check to see that the service name exists in one of the TNSNAMES.ORA files and add it if necessary.

    Make sure there are no syntax errors anywhere in the file.Particularly look for unmatched parentheses or stray characters. Any error in a TNSNAMES.ORA file makes it unusable.

    If possible, regenerate the configuration files using the Oracle Network Manager.
    SATHISH .

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •