Results 1 to 4 of 4
  1. #1
    Join Date
    Oct 2003
    Location
    Karachi
    Posts
    12

    Unanswered: ERROR: ORA-01004: default username feature not supported; logon denied

    Hi guys I m still waiting for the help regarding this problem I've tried all the options that u've mentioned

    Jawed

    Hi all

    I am using Oracle 9i (9.2.0) on Redhat Linux 9.0 and set the parameters as follows:

    1. in init.ora file at {Oracle_home}/dbs folder I set the values as below
    REMOTE_OS_AUTHENT=TRUE
    2. In sqlnet.ora file in {Oracle_home}/network/admin folder the values are at the server side
    NAMES.DEFAULT_DOMAIN = ssuet.edu.pk

    NAMES.DIRECTORY_PATH= (TNSNAMES, ONAMES, HOSTNAME)

    # sqlnet.authentication_services=(NTS)

    # REMOTE_OS_AUTHENT = TRUE

    # SQLNET.AUTHENTICATION_SERVICES=(NTS)

    All I have tried to enable/disable parameters in above mentioned files but change effect when athenticating from client side by supplying username with / and giving the error mentioned in subject line, but when i am logging with sqlplus / from linux telnet session it is working fine. Kindly help me in this regard


    Jawed Iqbal


    anacedent
    Guru

    The default for V9.2 is to NOT use initSID.ora file,
    but to use spfileSID.ora file instead.
    Are you REALLY sure Oracle is actually reading the initSID.ora file?
    What OS & OS version is the"client"?


    markrem
    Member

    You need remote_os_authent=true. It is false by default. I agree with the other poster that changing it in the init.ora file might have no impact since Oracle uses an spfile by default and ignores the init.ora.

    I think there are many things that can go wrong here, but given your error message I think the other poster put you on the right track.

    For example, in file sqlnet.ora the parameter sqlnet.authentication_services. Right now you have it commented out, which is good since the value you show only works on Windows but you are on Linux. Lookup the correct value for linux, then uncomment the parameter and see what happens.

    __________________
    Mark
    9i OCP



    jaggu
    Senior Member

    Yes, what the our friends says is true, oracle 9.2 uses spfile by default so any change in the initSID.ora will not be effective, restart the server by mentioning the parameter file as initSID.ora file, it should solve the problem

    To find what init file oracle is using use the following command

    select * from v$parameter where name like 'sp%'

    --jaggu



    Jawed
    Junior Member

    quote:
    --------------------------------------------------------------------------------
    Originally posted by anacedent
    The default for V9.2 is to NOT use initSID.ora file,
    but to use spfileSID.ora file instead.
    Are you REALLY sure Oracle is actually reading the initSID.ora file?
    What OS & OS version is the"client"?
    --------------------------------------------------------------------------------

    I m not sure that what init file is using with oracle but it is working fine on linux using os authentication but giving the mentioned error when authntication from client machine. OS running on client is XP/w2k/nt/w9x what should to set on client side and what to set on server side kindly help me in this regard


    Jawed
    Junior Member


    quote:
    --------------------------------------------------------------------------------
    Originally posted by markrem
    You need remote_os_authent=true. It is false by default. I agree with the other poster that changing it in the init.ora file might have no impact since Oracle uses an spfile by default and ignores the init.ora.

    I think there are many things that can go wrong here, but given your error message I think the other poster put you on the right track.

    For example, in file sqlnet.ora the parameter sqlnet.authentication_services. Right now you have it commented out, which is good since the value you show only works on Windows but you are on Linux. Lookup the correct value for linux, then uncomment the parameter and see what happens.
    --------------------------------------------------------------------------------



    I've tried to set parameter remote_os_athent=true in spfileSID.ora file but no impact. If you know the correct value for linux, plz inform me that i can try 2 solve my problem. Kindly also tell me that which parameters 2 b needed and in which file 2 set.

    JAwed

  2. #2
    Join Date
    Nov 2003
    Location
    Bangalore, INDIA
    Posts
    333

    Thumbs up

    Hi,

    Set SQLNET.AUTHENTICATION_SERVICES=(NTS) in the "sqlnet.ora" on the client and server.
    SATHISH .

  3. #3
    Join Date
    Jan 2004
    Location
    Venezuela
    Posts
    151

    Re: ERROR: ORA-01004: default username feature not supported; logon denied

    Are you attempting to get connection from a client with an authenticated OS user ?
    Joel Pérez

  4. #4
    Join Date
    Oct 2003
    Location
    Karachi
    Posts
    12
    Originally posted by satish_ct
    Hi,

    Set SQLNET.AUTHENTICATION_SERVICES=(NTS) in the "sqlnet.ora" on the client and server.

    Hi,

    I've already tried this parameter before posting a question
    Sir, kindly look at the question and solutions given by other guys.

    When I m trying to set the above mentioned parameter in sqlnet.ora on both client and server but the problem still was the same. But when i set the same parameter on Server it stops Os authentication on server.

    In current senario the OS authentication only succeds on Server side, but when I try to establish connection from client side it gives the error which i mentioned in subject line.

    Kindly help me in this regard


    Jawed

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •