Results 1 to 3 of 3
  1. #1
    Join Date
    Sep 2003
    Posts
    3

    Unanswered: Access 97 Exports SLOW

    I am using Access 97 to extract sales information from a FoxPro Database.
    We have recently moved everything to a new server (which I am told is a better spec than the old one).
    I use the Transfer Database command to export the info (150,000 records) to an access database residing on the same server.
    The problem is that when I want to re-run the update it takes ages (so long that even leaving it over night does not work).
    It appears to run 99% of the export (progress bar fils completely). But then seems to hang at the very end.
    Any suggestions or do you need more info?
    Garethg

  2. #2
    Join Date
    Oct 2003
    Location
    Ger
    Posts
    1,969
    Provided Answers: 1

    Re: Access 97 Exports SLOW

    Originally posted by garethg
    I am using Access 97 to extract sales information from a FoxPro Database.
    We have recently moved everything to a new server (which I am told is a better spec than the old one).
    I use the Transfer Database command to export the info (150,000 records) to an access database residing on the same server.
    The problem is that when I want to re-run the update it takes ages (so long that even leaving it over night does not work).
    It appears to run 99% of the export (progress bar fils completely). But then seems to hang at the very end.
    Any suggestions or do you need more info?
    Garethg
    150,000 Records are not too much, but try to split your table and try the import again. See wheather still slow or not.

  3. #3
    Join Date
    Sep 2003
    Posts
    3
    Thanks for your suggestion.
    Since I made the post I had tried everything (including praying).
    I cleaned down the original table and ran compact database & repair to make sure everything was neat & tidy.
    I ran the export procedure for a single months worth of data and it worked fine (10,000) records.

    I know that the system works because I have been using it for over 6 months. The problem seems to have occured since we changed over to the new system (Windows 2000, brand new server dedicated to fewer applications with heaps more storage, CPU power and memory).

    When I run the process it appears to update the file in batches (refreshing the details on the destination file shows it increase from 10Mb then to around 20Mb then what appears to be a complete lack of anything)

    I had IT monitor the CPU/memory usage while the process is running and they said it was using around 20% of resources (it peaked above everything else as expected) but it just seems like it can't finish of the export.

    I even created a brand new destination file with the same (empty) table structure, and it still does not work.

    IT are calling in some boffs from IBM to look at the server, but I think it may be an issue with access.

    Something I may not have indicated in my original post is that we are using MS Access 97 Run Time eddition: anyone know if this has some limitations set?

    I also exported the same records 100,000+ to a print preview report and again it manages these fine, the problem seems to be mainly to do with it *completeing* the export rather than the bulk of data.

    Any suggestions would be much appreciated.
    GarethG

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •