Results 1 to 5 of 5
  1. #1
    Join Date
    Jan 2004
    Location
    Reston, VA
    Posts
    4

    Unanswered: DB2 V8 Licensing Issues

    Hi There,
    We just finished installing V8 Fixpak 4 on AIX 5.1 and we updated the licnece and it looks like this.

    Product Name = "DB2 Enterprise Server Edition"
    Product Password = "DB2ESE"
    Version Information = "8.1"
    Expiry Date = "Permanent"
    Registered Connect User Policy = "Disabled"
    Number Of Entitled Users = "5"
    Enforcement Policy = "Soft Stop"
    Number of processors = "4"
    Number of licensed processors = "1"
    Annotation = ""
    Other information = ""

    When we are trying to update the number of processors we are running into problems. Any Idea what might be the problem????
    Here is the output

    db2licd -n DB2ESE 4
    exec(): 0509-036 Cannot load program db2licd because of the following errors:
    0509-130 Symbol resolution failed for /usr/lib/threads/libc.a(aio.o) bec
    ause:
    0509-136 Symbol kaio_rdwr (number 0) is not exported from
    dependent module /unix.
    0509-136 Symbol listio (number 1) is not exported from
    dependent module /unix.
    0509-136 Symbol acancel (number 2) is not exported from
    dependent module /unix.
    0509-136 Symbol iosuspend (number 3) is not exported from
    dependent module /unix.
    0509-136 Symbol aio_nwait (number 4) is not exported from
    dependent module /unix.
    0509-130 Symbol resolution failed for /usr/opt/db2_08_01/lib/libdb2e.a(s
    hr.o) because:
    0509-136 Symbol aio_nwait (number 507) is not exported from
    dependent module /usr/lib/threads/libc.a(aio.o).
    0509-192 Examine .loader section symbols with the
    'dump -Tv' command.




    Thanks
    Kiran

  2. #2
    Join Date
    Aug 2001
    Location
    UK
    Posts
    4,650

    Re: DB2 V8 Licensing Issues

    db2licd -n DB2ESE 4

    should be db2licm -n DB2ESE 4
    Visit the new-look IDUG Website , register to gain access to the excellent content.

  3. #3
    Join Date
    Jan 2004
    Location
    Reston, VA
    Posts
    4
    we did db2licm -n DB2ESE 4 , Still same message

  4. #4
    Join Date
    Oct 2003
    Posts
    706
    Obviously a runtime-library problem of some kind. I've seen wierdnesses like this after something fundamental like 'glibc' was updated in a [Linux] system.

    ldconfig?

    Time to ask your vendor?
    ChimneySweep(R): fast, automatic
    table repair at a click of the
    mouse! http://www.sundialservices.com

  5. #5
    Join Date
    Jan 2004
    Location
    Reston, VA
    Posts
    4
    Guys....This Issue Has been resolved. Apparently my SA forgot to make changes to AIX to set asynchronous I/O ON. Its working fine now. Thanks for your help



    Kiran

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •