Results 1 to 2 of 2
  1. #1
    Join Date
    Sep 2003
    Location
    Hanoi- Vietnam
    Posts
    27

    Angry Unanswered: frm-41214 and frm-41217

    Hi Experts,

    I have tried alot but I can't sovle this problem. I hope get more and more your helps.
    As you know, my problem is call report from Oracle9i Form.
    I deploy my application in 9iDS. When I call report from Form I get error Frm-41214 and frm-41217. I'm not use SSO for report and I have set SSO in rwservlet.properties=False. I don't know why?
    I remember some month ago I have config successfully this problem but now I can. Before I only set SSO=No then nothing happen.
    I think codes to Run_Report_Object is not reason because I succesed before.

    This is My trace file. I hope get your helps.

    [2004/1/16 9:36:47:156] Debug 50103 (RWClient:RWClientInit): Get ORACLE_HOME from environment variable, oracle home: D:\OraNT\9iDS
    [2004/1/16 9:36:47:281] Exception 50125 (oracle.ias.repository.schema.SchemaException: Schema Configuration Files could not be located
    at oracle.ias.repository.local.IASPropertyCache.loadC ache(IASPropertyCache.java:146)
    at oracle.ias.repository.local.IASPropertyCache.readV alue(IASPropertyCache.java:58)
    at oracle.ias.repository.IASSchema.init(IASSchema.jav a:138)
    at oracle.ias.repository.IASSchema.<init>(IASSchema.j ava:113)
    at oracle.ias.repository.SchemaManager.<init>(SchemaM anager.java:64)
    at oracle.reports.utility.OIDConnection.init(OIDConne ction.java:55)
    at oracle.reports.rwclient.RWClient.RWClientInit(RWCl ient.java:471)
    at oracle.reports.rwclient.RWClient.init(RWClient.jav a:210)
    at com.evermind.server.http.HttpApplication.loadServl et(HttpApplication.java:1687)
    at com.evermind.server.http.HttpApplication.findServl et(HttpApplication.java:4020)
    at com.evermind.server.http.HttpApplication.initPrelo adServlets(HttpApplication.java:4119)
    at com.evermind.server.http.HttpApplication.initDynam ic(HttpApplication.java:579)
    at com.evermind.server.http.HttpApplication.<init>(Ht tpApplication.java:376)
    at com.evermind.server.Application.getHttpApplication (Application.java:657)
    at com.evermind.server.http.HttpServer.getHttpApplica tion(HttpServer.java:663)
    at com.evermind.server.http.HttpSite.getApplication(H ttpSite.java:387)
    at com.evermind.server.http.HttpRequestHandler.proces sRequest(HttpRequestHandler.java:378)
    at com.evermind.server.http.HttpRequestHandler.run(Ht tpRequestHandler.java:243)
    at com.evermind.util.ThreadPoolThread.run(ThreadPoolT hread.java:64)
    ): Internal error oracle.ias.repository.schema.SchemaException: Schema Configuration Files could not be located
    [2004/1/16 9:36:47:281] Debug 50103 (OIDConnection:init): Failed to connect to OID server
    [2004/1/16 9:36:47:312] Debug 50103 (KeyMapParser:readKeyMapFile): file: D:\OraNT\9iDS\reports\conf\cgicmd.dat
    [2004/1/16 9:36:48:500] Info 50103 (RWClient:initCORBA): Reuse existing server: rephrms
    [2004/1/16 9:36:48:546] Debug 50103 (RWClient:doGet): QueryString: report=D:\app\hrms\reps\test.rdf&desformat=HTML&de stype=Cache&server=rephrms&userid=app
    [2004/1/16 9:36:48:546] Info 50103 (RWClientrocessRequest): queryString:report=D:\app\hrms\reps\test.rdf&desfo rmat=HTML&destype=Cache&server=rephrms&userid=app
    [2004/1/16 9:36:48:546] Debug 50103 (RWClientUtility:getReportsServer): server: rephrms
    [2004/1/16 9:36:48:578] Debug 50103 (AuthManager:getAuthId): server secure: false
    [2004/1/16 9:36:48:593] Debug 50103 (RWClientUtility:getReportsServer): server: rephrms
    [2004/1/16 9:36:48:593] Debug 50103 (RWClient:runReport): cmdline: expiredays=0 report=D:\app\hrms\reps\test.rdf jobname=D:\app\hrms\reps\test.rdf desformat=HTML authid=RWUser server=rephrms destype=Cache userid=app@dev SERVER_NAME="hungdq" SERVER_PORT=8888 SCRIPT_NAME="/rwservlet" SERVER_PROTOCOL="HTTP/1.1" REMOTE_ADDR="192.168.8.45" REMOTE_HOST="Hungdq" ACCEPT_LANGUAGE="en-us" USER_AGENT="Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.2; .NET CLR 1.1.4322)"
    [2004/1/16 9:36:48:593] Debug 50103 (ReportRunner:connectToServer): New Connection request for userid: RWUser to server: rephrms
    [2004/1/16 9:36:48:671] Debug 50103 (ReportRunner:connectToServer): Connection succeeded for user: RWUser to server: rephrms
    [2004/1/16 9:36:49:406] Info 51022 (ReportRunner:Release): Connection object has been released
    [2004/1/16 9:36:49:406] Exception 501 (): Unable to connect to the specified database.
    exception oracle.reports.RWException {
    oracle.reports.RWError[] errorChain={struct oracle.reports.RWError {
    int errorCode=501,
    java.lang.String errorString="Unable to connect to the specified database.",
    java.lang.String moduleName="REP"
    }}
    }
    at oracle.reports.RWExceptionHelper.read(RWExceptionH elper.java:28)
    at oracle.reports.server._ConnectionStub.runJob(_Conn ectionStub.java:974)
    at oracle.reports.client.ReportRunner.dispatchReport( ReportRunner.java:266)
    at oracle.reports.rwclient.RWReportRunner.dispatchRep ort(RWReportRunner.java:94)
    at oracle.reports.rwclient.RWClient.runReport(RWClien t.java:1425)
    at oracle.reports.rwclient.RWClient.processRequest(RW Client.java:1265)
    at oracle.reports.rwclient.RWClient.doGet(RWClient.ja va:289)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:244)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:336)
    at com.evermind.server.http.ResourceFilterChain.doFil ter(ResourceFilterChain.java:59)
    at oracle.security.jazn.oc4j.JAZNFilter.doFilter(JAZN Filter.java:283)
    at com.evermind.server.http.ServletRequestDispatcher. invoke(ServletRequestDispatcher.java:523)
    at com.evermind.server.http.ServletRequestDispatcher. forwardInternal(ServletRequestDispatcher.java:269)
    at com.evermind.server.http.HttpRequestHandler.proces sRequest(HttpRequestHandler.java:735)
    at com.evermind.server.http.HttpRequestHandler.run(Ht tpRequestHandler.java:243)
    at com.evermind.util.ThreadPoolThread.run(ThreadPoolT hread.java:64)

    [2004/1/16 9:36:49:406] Debug 50103 (RWClientUtility:isFromPortal): portal: null
    [2004/1/16 9:36:49:406] Debug 50103 (RWClientUtility:isFromPortal): webdbversion: null

    Thanhs alot
    Last edited by hungdq; 01-16-04 at 00:09.

  2. #2
    Join Date
    Sep 2003
    Location
    Hanoi- Vietnam
    Posts
    27
    Hi,

    I want to add some
    When I call report from URL using in-process server It work fine but when I replace it with other report server It raise error rep-501 unable to connect specific database.
    My host is hungdq and when I use this URL. I work fine:
    http://hungdq:8888/reports/rwservlet...ver=rep_hungdq

    When I type:
    http://hungdq:8888/reports/rwservlet...&server=repsrv

    I raise error. repsrv is report server i create following document guide.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •