Results 1 to 4 of 4
  1. #1
    Join Date
    Jan 2004
    Posts
    17

    Unanswered: Help setting up an ODBC in WinXP to RedHat and IDS 9.20?

    I need help to setup an ODBC in Windows XP to Linux IDS 9.20, here is what I have set.

    Added line to C:\WINDOWS\system32\drivers\etc\services
    on_ourdb 1526/tcp #IDS 9.2
    -Match server etc/services


    Added lines to C:\WINDOWS\system32\drivers\etc\hosts
    192.168.1.106 ourdb.something.com
    192.168.1.106 ourdb
    -Match etc/hosts


    Seting up ODBC using Informix 3.34 32-bit
    Data source name: db_source

    Server Name: our_in4mix
    -Matching opt/informix/etc/onconfig

    Host Name: ourdb
    -Matching etc/hosts

    Service: our_informix
    -Matching INFORMIXSERVER

    Protocol: onsoctcp
    -Matching opt/informix/etc/sqlhosts

    I think everything is right, but it does not work!
    Thanks for your help,
    James...

  2. #2
    Join Date
    Aug 2003
    Location
    India
    Posts
    262

    Re: Help setting up an ODBC in WinXP to RedHat and IDS 9.20?

    Hi there,

    What error are you getting. In ODBC instead of specifing the name for hostname and service, try entering the IP addr for host eg. 10.1.20.20 and the service nos eg. 1527. Also change the protocol to olsoctcp.

    Regards,

    lloyd


    Originally posted by stedlj
    I need help to setup an ODBC in Windows XP to Linux IDS 9.20, here is what I have set.

    Added line to C:\WINDOWS\system32\drivers\etc\services
    on_ourdb 1526/tcp #IDS 9.2
    -Match server etc/services


    Added lines to C:\WINDOWS\system32\drivers\etc\hosts
    192.168.1.106 ourdb.something.com
    192.168.1.106 ourdb
    -Match etc/hosts


    Seting up ODBC using Informix 3.34 32-bit
    Data source name: db_source

    Server Name: our_in4mix
    -Matching opt/informix/etc/onconfig

    Host Name: ourdb
    -Matching etc/hosts

    Service: our_informix
    -Matching INFORMIXSERVER

    Protocol: onsoctcp
    -Matching opt/informix/etc/sqlhosts

    I think everything is right, but it does not work!
    Thanks for your help,
    James...

  3. #3
    Join Date
    Jan 2004
    Posts
    17
    I have tryied both putting in the IP and in the port number.

    From within the ODBC setup I click on "Apply & Test Connection" it tries for about a min then I get "Test was NOT successful.[Informix][Informix ODBC Drive][Informix]Attempt to connnect to database server (ourdb) failed."

    I tryied changing to olsoctcp as well and got the same answer.

    Informix maybe messed up, I mean it seems to be running fine, but I can not find any patch/upgrade information. IBM's website offers zip in help.

    James...

  4. #4
    Join Date
    Jan 2004
    Posts
    17
    I found the problem, it was in the sqlhosts file I had "ourdb" as hostname when I change it to the box IP I can connect.

    It is always some little thing that the intructions gloss over.

    Thanks all!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •