Results 1 to 3 of 3
  1. #1
    Join Date
    Jul 2003

    Unanswered: Error calling RPC to linked server

    I am trying to call an RPC from SQL2KSP3 to Sybase ASE 12.5. SQL2K is on an IBM Intel Server running Win2KSP4, ASE is on an IBM RS6000 w/ AIX 5.2.

    I have the ASE server set up as a linked server in SQL 2000, and doing queries is working fine, i.e. I can
    SELECT * FROM asesrvr.testdb.dbo.tablename
    and get back all the data in tablename from the testdb database on the ASE server asesrvr.

    However, when I try to run an RPC using the same syntax, I get a generic 7212 error (Could not execute procedure 'procname' on remote server 'asesrvr'. I am calling the rpc with
    DECLARE @output char(1)
    EXEC asesrvr.testdb.dbo.procname @output output

    I'm using Sybase's ASE OLEDB provider; on the Linked Server Properties, I have

    General Tab
    Product name: asesrvr
    Data source: devprod
    Provider string: <empty>
    Location: greyed out
    Catalog: <empty>

    Security Tab
    One local login, sa, which has impersonate checked as the sa passwords on the two servers are the same (I want to eliminate security as an issue while I try to get this working).

    Server Options Tab
    Collation Compatible: checked
    Data Access: checked
    RPC: checked
    RPC Out: checked
    Use Remote Collation: unchecked
    Collation Name: <empty>
    Connection Timeout: 0
    Query Timeout: 0

    SQL2K's @@version is
    Microsoft SQL Server 2000 - 8.00.760 (Intel X86) Dec 17 2002 14:22:05 Copyright (c) 1988-2003 Microsoft Corporation Standard Edition on Windows NT 5.0 (Build 2195: Service Pack 4)

    Any ideas on how I can troubleshoot this further? It does not appear to be limited to this one procedure (this one only has one output parameter and one line of code, so it's about as simple as it can get for testing purposes). Again, queries work fine, so the linked server itself is connected and working, at least for queries.

    Thanks very much for your help,


  2. #2
    Join Date
    Jul 2003
    San Antonio, TX
    Have you tried to execute the proc on the linked server itself?

  3. #3
    Join Date
    Jul 2003
    Originally posted by rdjabarov
    Have you tried to execute the proc on the linked server itself?
    Yes, everything works perfectly on the linked server. It's just from the SQL Server that it doesn't work.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts