Results 1 to 2 of 2
  1. #1
    Join Date
    Jan 2004

    Unhappy Unanswered: HELP ! Who owns the oracle process on AIX

    I am having ORA-01157 errors after I completed a aix OS replacement needed afer a disk crash. I have tried everything for days but can not seem to gt past this error. I did a ps -ef | grep oracle and saw that the oracle process was owned by root. Is this correct. Any thoughts would help as I have been trying to get this system up for two weeks.


    Last edited by PDELLIS; 01-17-04 at 22:25.

  2. #2
    Join Date
    Jan 2004
    The owner of the oracle process should be the oracle software owner (user set up to install oracle).

    It should certainly not be root.

    You must make sure the software owner has the same name and group as they had on the lost system.

    Permissions on the oracle executable should have setuid:

    -rwsr-sr-x 1 oracle dba

    If you don't have this then the following will do the trick (logged in as the oracle software owner of course)

    chmod 7755 $ORACLE_HOME/bin/oracle

    If you still get ORA-1157 errors you *must* get the underlying O/S error.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts