Results 1 to 4 of 4

Thread: 8i Migration

  1. #1
    Join Date
    Jan 2004
    Location
    Canada
    Posts
    2

    Unanswered: 8i Migration

    Hello,

    I am trying to migrate 8.1.7 to 9i. Oracle 8i is installed on machine1. I installed 9i on machine 2 and copied the dB in OS level. I read through the 9i Migration document and taking every step as listed, but when I reached step 1 of 5 (Where you select the SID and press next) I am getting ORA-01034 (Oracel not available).

    So I tried to start the dB from SQLPLS and I received error ORA-03113 (end-of-file communication). Thinking that I may not be able to open before migrating to 9i I mounted the dB using STARTUP MOUNT command. Now when I did step 1 of 5 it asks me to shutdown the dB first!

    I cound not also test 'Net configuration assistant' (Getting ORA-12514).

    The question is:
    1. Should I setup Net configuration before migration or after migrating
    2. When copying the dB from another computer what is the first step I need to do before attempting to migrate the dB?

    Thanks in advance.
    Suresh

  2. #2
    Join Date
    Aug 2003
    Location
    Where the Surf Meets the Turf @Del Mar, CA
    Posts
    7,776
    Provided Answers: 1
    Too few details provided.
    No OS & no OS version mentioned.
    "migrate" using EXACTLY which method/utility?

    Here is what I did on Friday.
    1) Shutdown V7.3.4.5 DB
    2) copied files using "rcp" commands onto new system
    3) On new system started cloned copy of V7.3.4.5 on new system.
    4) Changed by environment to support V9.2 Oracle
    5) invoked "dbua" utility & clicked until the wizard completed.
    6) Declared victory with a V9.2 DB after 'dbua' terminated

  3. #3
    Join Date
    Jan 2004
    Location
    Canada
    Posts
    2
    Hi anacedent,

    I am using WIN 2000 (version 5 with SP 4) and using Oracle "Database Upgrade Assistant".

    2) copied files using "rcp" commands onto new system
    WHAT IS RCP?
    3) On new system started cloned copy of V7.3.4.5 on new system.
    DID YOU OPEN THE DB OR JUST MOUNTED THE DB? WHEN I TRIED TO OPEN THE DB I RECEIVED AN ERROR SAYING THAT I NEED TO OPEN IN MIGRATE MODE.
    4) Changed by environment to support V9.2 Oracle
    WHAT ENVIORNMENT I NEED TO CHANGE? I ADDED THE ORACLE_HOME AND ORACLE_SID TO MY ENV.

    Did you setup the "Net configuration " before migration?

    Thanks
    Suresh

  4. #4
    Join Date
    Aug 2003
    Location
    Where the Surf Meets the Turf @Del Mar, CA
    Posts
    7,776
    Provided Answers: 1
    I'm running on Solaris

    >>2) copied files using "rcp" commands onto new system
    >WHAT IS RCP?
    "rcp" is a unix command that does a Remote CoPy.
    >>3) On new system started cloned copy of V7.3.4.5 on new system.
    >DID YOU OPEN THE DB OR JUST MOUNTED THE DB? WHEN I TRIED TO
    >OPEN THE DB I RECEIVED AN ERROR SAYING THAT I NEED TO OPEN
    >IN MIGRATE MODE.
    "started" as in "startup" & available for use.
    >>4) Changed by environment to support V9.2 Oracle
    >WHAT ENVIORNMENT I NEED TO CHANGE? I ADDED THE >ORACLE_HOME AND ORACLE_SID TO MY ENV.
    Plus a couple of others; PATH & LD_LIRBRAY_PATH

    >Did you setup the "Net configuration " before migration?
    Not ever.
    P.S.
    SQL*Net is NOT required to install, run or use any Oracle DB;
    as long as all operations are done on the same system where the DB resides.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •