Results 1 to 3 of 3

Thread: Db2 Load

  1. #1
    Join Date
    Jan 2004
    Posts
    2

    Unanswered: Db2 Load

    hello @ all,
    my problem:
    i want to load a sequentiell file in a OS/390 DB2 using the LOAD-utility.
    in the file there are fields in the format '0000000000000,00+' (zoned,17 characters).
    the DB2-load utility allows only the format '+0000000000000,00'. i tried this with 'decimal external (15,2)'.
    Does somebody knows a solution for this problem, because i don't want to change my input-file.

    thank you

  2. #2
    Join Date
    Nov 2003
    Location
    Germany
    Posts
    62
    Hi

    Did you try the load with decimal zoned?

  3. #3
    Join Date
    Jan 2004
    Posts
    2
    hi walter,
    thanks for your reply.
    yes i tried also with decimal zoned, but it didn't work. I have problem with the description in the manuel. the format is shown as "znznzn....,sn". where n is a digit of 4 bits of a byte or something like that.
    Maybe they mean the hex value (X'1' from X'F1' in ebcdic).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •