Results 1 to 3 of 3
  1. #1
    Join Date
    Jan 2004
    Location
    Auxerre, France
    Posts
    6

    Red face Unanswered: backup and Error SQL0980C

    Hi everyone,
    During a "Backup Database" command an SQL0980C error hapenned. It seems that this error is link to a harware failure or a problem whith my database. I made some tests on my Hard disk wich seems being OK and a db2dart /db did not reveals any error.
    Furthermore I have the same scripts wich is excecuted in several places and there no error shown...
    To sum-up : I'm lost, please help
    P.S. Here a link to an article on IBM website where they're talking about this error, but i don't see what I can do...
    http://www-1.ibm.com/support/docview...id=swg21081379

    C U arround
    Kerseub
    Last edited by Kerseub; 01-22-04 at 11:11.

  2. #2
    Join Date
    Aug 2001
    Location
    UK
    Posts
    4,650

    Re: backup and Error SQL0980C

    You are likely to have some information in the db2diag.log file

    Cheers
    Sathyaram
    Visit the new-look IDUG Website , register to gain access to the excellent content.

  3. #3
    Join Date
    Jan 2004
    Location
    Auxerre, France
    Posts
    6

    Re: backup and Error SQL0980C

    Yes and there's something pretty intresting :

    Starting a full database backup.

    2004-01-22-16.45.01.859000 Instance:DB2 Node:000
    PID:1092(db2syscs.exe) TID:960 Appid:none
    buffer pool services sqlbcres Probe:25

    DiagData
    0801 0000 ....

    2004-01-22-16.45.01.875000 Instance:DB2 Node:000
    PID:1092(db2syscs.exe) TID:960 Appid:none
    buffer pool services sqlbrdpg Probe:1143

    DIA8400C A bad page was encountered.
    ZRC=0x86020001

    2004-01-22-16.45.01.875001 Instance:DB2 Node:000
    PID:1092(db2syscs.exe) TID:960 Appid:none
    buffer pool services sqlbrdpg Probe:1143

    Obj={pool:2;obj:109;type:1} State=x27 Page=264 Cont=0 Offset=264 BlkSize=12
    BadPage
    and later

    ** Failure on first attempt to read the page **
    0100 0286
    finally

    ** Second read was also unsucessful ** 0100 0286

    So I guess that the problem is coming from this god***** object 109 don't you think ?
    In the db2dart report it match whith a certain table (I dont what it is for but anyway...) .
    Now I think that the solution is to declare this table through a db2dart /MI commmand?
    Is it the only solution? Did I risk to crash the database?

    Hapiness is close, I feel it !!!

    P.S. For information : the machine use W2000 whith DB2/NT 8.1.0

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •