Results 1 to 2 of 2
  1. #1
    Join Date
    Jan 2004

    Unanswered: Problems with DBI, DBD::Oracle with Oracle9i

    I'm having a problem getting DBI/DBD::Oracle working for a new Oracle9i installation.

    My connection string, which worked fine under 8i is:
    $Conn = DBI->connect("dbi:Oracle:$dsn", "$user", "$pw") or die "$DBI::errstr\n";

    I've seen references to this error all over the place, but nobody has offered any fixes (except to go back to 8i, which really isn't practical).

    I cleaned, get-ted, made (via cpan) with proper $ORACLE_HOME, $LD_LIBRARY_PATH, $SHLIB_PATH. I've run out of things to try to get this to work...
    Does Perl-DBI not work for Oracle9i, or is there something else I should try?

    The error thrown is:
    install_driver(Oracle) failed: Can't load '/usr/local/lib/perl5/site_perl/5.8.2/i686-linux/auto/DBD/Oracle/' for module DBD::Oracle: cannot open shared object file: No such file or directory at /usr/local/lib/perl5/5.8.2/i686-linux/ line 229.
    at (eval 1) line 3
    Compilation failed in require at (eval 1) line 3.
    Perhaps a required shared library or dll isn't installed where expected

    J Murray

    Perl: v5.8.2 built for i686-linux
    Bundle:BI : 1.40
    DBD::Oracle 1.14
    Redhat kernel: 2.4.20-20.7smp

  2. #2
    Join Date
    Jan 2004

    Thumbs up Re: Problems with DBI, DBD::Oracle with Oracle9i

    This problem was fixed by doing the install without cpan. I downloaded the tarred gzip, set the environment, and did a manual make/make install of DBD::Oracle, and it worked without a hitch. I'm not sure how the bug manifests itself when doing the make/install from cpan, but this is a definite workaround.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts