Results 1 to 5 of 5
  1. #1
    Join Date
    Jan 2004
    Posts
    5

    Question Unanswered: MS03-031 Security Patch indexed view bugs...

    Hey!

    Has anybody here had any issues with the MS03-031 security patch and SQL 2000 on Windows 2003?

    We recently installed this patch on one of our test SQL 2000 machines, and the performance of queries running on this machine have gone up (gotten worse) by at least 10X.

    We use indexed views and all queries are run with WITH(NOEXPAND) to force the indexed view to be used.

    Anyway, after the patch was installed, the queries on the indexed view will ONLY use the clustered index, and not any of the other indexes, causing a Clustered Index Scan.

    I removed the patch (well, re-installed SQL) patched it up to SP3a, and performance is back to normal.

    Anybody experience anything similar?
    Paul

  2. #2
    Join Date
    Sep 2003
    Posts
    522
    nope, but did you contact m$ on this? and if you are planning on that, - can you post what was their resolution/action/advice/etc?

  3. #3
    Join Date
    Jan 2004
    Posts
    5
    Originally posted by ms_sql_dba
    nope, but did you contact m$ on this? and if you are planning on that, - can you post what was their resolution/action/advice/etc?
    Yeah, Im going to contact MS about this and see what they have to say... I have heard that security patch issues are free, but Ill believe it when I see it!

    Just thought Id post in a few places to see if it was a known issue or not.

    Thanks!
    Paul

  4. #4
    Join Date
    Sep 2003
    Posts
    522
    we've never use noexpand here. did you try to experiment with the syntax and see if it's their keyward expansion algorythm that chokes maybe on WITH? have you tried to exclude the hint all together and see if there is a difference?

  5. #5
    Join Date
    Jan 2004
    Posts
    5
    Originally posted by ms_sql_dba
    we've never use noexpand here. did you try to experiment with the syntax and see if it's their keyward expansion algorythm that chokes maybe on WITH? have you tried to exclude the hint all together and see if there is a difference?
    I did try excluding the WITH(NOEXPAND), but it then refuses to even use the indexed view at all, and instead tries to use the base tables.

    Thanks!
    Paul

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •