Results 1 to 7 of 7

Thread: ORA-29540 Error

  1. #1
    Join Date
    Jan 2004
    Posts
    4

    Exclamation Unanswered: ORA-29540 Error

    I have an 8.1.7 db and a client trying to connect using jdbc. On the connection attempt I get ORA-29540: class oracle/plsql/net/InternetAddress does not exist. The install of the server was standard with all options selected. Does anyone know anything about this? Thanks in advance!

  2. #2
    Join Date
    Aug 2003
    Location
    Where the Surf Meets the Turf @Del Mar, CA
    Posts
    7,776
    Provided Answers: 1
    One data point does not indicate any trend.

    Is Java successfully installed in the DB?

    Has this ever worked?

    What's changed?

  3. #3
    Join Date
    Jan 2004
    Posts
    4
    Originally posted by anacedent
    One data point does not indicate any trend.

    Is Java successfully installed in the DB?

    Has this ever worked?

    What's changed?
    This is a new installation of an application - Cognos Metrics Manager. I have another application installed as well that uses JDBC and that appears to be working. However, in the Tomcat logs, I am seeing the ORA-29540 error which indicates something is amiss.

    What is the best way to verify Java is fully installed? Sorry if this is a rookie question...

  4. #4
    Join Date
    Aug 2003
    Location
    Where the Surf Meets the Turf @Del Mar, CA
    Posts
    7,776
    Provided Answers: 1
    select status, count(status) from all_objects
    where object_type='JAVA CLASS'
    group by status;

    STATUS COUNT(STATUS)
    ------- -------------
    VALID 6434
    You should thousands of valid objects & ZERO invalid objects.

  5. #5
    Join Date
    Jan 2004
    Posts
    4
    I get Valid 6440. Is this appropriate?b

  6. #6
    Join Date
    Aug 2003
    Location
    Where the Surf Meets the Turf @Del Mar, CA
    Posts
    7,776
    Provided Answers: 1
    "Unfortunately, there is another script, initplsj.sql (located in ORACLE_HOME/rdbms/admin) which is supposed to be called by the initjvm.sql script. This does not occur. To fix the problem, run the initplsj.sql script (as SYS). "

    HTH & YMMV

    HAND!

  7. #7
    Join Date
    Jan 2004
    Posts
    4

    Thumbs up Worked

    Thanks for all the help - the last script worked.

    Casey

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •