Results 1 to 4 of 4
  1. #1
    Join Date
    Jan 2004
    Location
    Chicago, IL
    Posts
    2

    Question Unanswered: SQL Agent Will Not Run

    I am running SQL 2000 with SP3a and Windows Server 2003 successfully. I have a associate that is attempting to set up the same configuration. Our settings match identically, but his SQL agent will not start. I have checked everything I can think of but it still will not start on his network, yet works perfectly fine on mine. The error he is getting is that the SA account failed to log in properly, yet the password is correct. Any suggestions?

  2. #2
    Join Date
    Jul 2003
    Location
    San Antonio, TX
    Posts
    3,662
    SQLAgent is a service, and cannot use SA as a logon account. It has to be a valid Windows account, or a System account.

  3. #3
    Join Date
    Jan 2004
    Location
    Chicago, IL
    Posts
    2
    In enterprise manager, under management then under SQL Server Agent Properties, I have my system running under “System Account” for service startup account. As for the main SQL Server Registration Properties, I have “Use SQL Server Authentication” and my SA user and a password. In services, I have both SQLSERVERAGENT and MSSQLSERVER set for Automatic Startup, and Log On As Local System.

    I can not understand why these settings have been working fine for me, but he cannot get his to run. Is there a 5th setting I am forgetting about that requires user login information?

  4. #4
    Join Date
    Jan 2003
    Location
    Massachusetts
    Posts
    5,799
    Provided Answers: 11
    Did your associate install SQL Server with Mixed authentication (in EM properties of a server, security tab)? The default is Windows authentication only.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •