Page 1 of 2 12 LastLast
Results 1 to 15 of 17

Thread: port 1433

  1. #1
    Join Date
    Sep 2003
    Posts
    21

    Unanswered: port 1433

    Did a search on port 1433 but nothing came up in the search.
    This question is more geared to DBAs more then SQL developers.

    I have a SQL 2000 server on a win2k3 machine. For some reason it will not listen in on TCP port 1433.
    Shared memory and Named Pipes do though.

    I checked the Server Network Utility and I see TCP/IP listed right under Named Pipes and I see that the default port is 1433.

    Any ideas how to get SQL to listen on that port?

  2. #2
    Join Date
    Jul 2003
    Location
    The Dark Planet
    Posts
    1,401
    Default instances of SQL Server use TCP port 1433 by default. Named instances, however, dynamically assign an unused TCP port number the first time the instance is started. The named instance can also dynamically change it's TCP port address on a subsequent startup if the original TCP port number is being used by another application. SQL Server only dynamically changes to an unused TCP port if the port it is currently listening on was dynamically selected. That is, if the port was statically selected (manually), SQL Server will display an error and continue to listen on other ports. It is unlikely another application would attempt to use 1433 since that port is registered as a well-known address for SQL Server.
    Get yourself a copy of the The Holy Book

    order has no physical Brett in The meaning of a Kaiser . -database data

  3. #3
    Join Date
    Sep 2003
    Posts
    21
    I like to thank you for taking the time to reply to my post.


    Yes, you are correct, SQL is supposed to default to 1433. My other install of SQL server defaults to port 1433.

    The particular install of MS SQL 2000 I'm writing about does default to port 1433, or so the Server Network Utility says.

    My problem is SQL server will not listen on any ports.


    2004-02-02 16:39:47.39 server SQL server listening on Shared Memory, Named Pipes.

    This is a cut paste from me ERRORLOG.

    Notice, that TCP is missing from that list.
    I just went back into Server Network Utility and I can plainly see that TCP/IP is under Named Pipes and it is supposed to default to port 1433.

    This is why I'm so confused.

  4. #4
    Join Date
    Jul 2003
    Location
    The Dark Planet
    Posts
    1,401
    Originally posted by ScientificLee
    I like to thank you for taking the time to reply to my post.


    Yes, you are correct, SQL is supposed to default to 1433. My other install of SQL server defaults to port 1433.

    The particular install of MS SQL 2000 I'm writing about does default to port 1433, or so the Server Network Utility says.

    My problem is SQL server will not listen on any ports.


    2004-02-02 16:39:47.39 server SQL server listening on Shared Memory, Named Pipes.

    This is a cut paste from me ERRORLOG.

    Notice, that TCP is missing from that list.
    I just went back into Server Network Utility and I can plainly see that TCP/IP is under Named Pipes and it is supposed to default to port 1433.

    This is why I'm so confused.
    Open SQL Server Network Utility ... first disable TCP/IP ...bounce sql service ... enable TCP/IP ... bounce sql service again ... check and see if you get it.
    Last edited by Enigma; 02-02-04 at 17:49.
    Get yourself a copy of the The Holy Book

    order has no physical Brett in The meaning of a Kaiser . -database data

  5. #5
    Join Date
    Sep 2003
    Posts
    21
    Thanks again for such a quick reply.

    Yes, Named Pipes and TCP/IP are both enabled. They always were. I have stoped and started SQL server via the Service Manger and even rebooted the box once.

    Nothing has worked.

  6. #6
    Join Date
    Jul 2003
    Location
    The Dark Planet
    Posts
    1,401
    Originally posted by ScientificLee
    Thanks again for such a quick reply.

    Yes, Named Pipes and TCP/IP are both enabled. They always were. I have stoped and started SQL server via the Service Manger and even rebooted the box once.

    Nothing has worked.
    Somerthing I found in The Holy Book (SQL Server Books Online).

    Note TCP/IP networking must be enabled before running SQL setup.
    Might this be the case ???

    More >>>
    The correct network protocols should already be installed on the client and server. Network protocols are typically installed during Windows setup; they are not part of SQL Server Setup. A SQL Server Net-Library will not work unless its corresponding network protocol is already installed on both the client and server.
    Last edited by Enigma; 02-02-04 at 17:54.
    Get yourself a copy of the The Holy Book

    order has no physical Brett in The meaning of a Kaiser . -database data

  7. #7
    Join Date
    Sep 2003
    Posts
    21
    Hmm,

    I read that in microsoft's website.
    TCP/IP is running. I can hit websites, telnet etc.

    The funniest thing is that I can connect to the SQL server through Enterprise Manager (EM) and Query Analyzer (QA) from my workstation. I don't know what network protcols are being used though.

    I also did a portQuery to see what ports SQL server is listening on. No dice. I've even changed the port to listen to via the Server Network Utility. That didn't work either.

    I checked the path directory for the TCP/IP network libaray but they all go to C:\Program Files\Microsoft SQL Server\MSSQL\Binn.

  8. #8
    Join Date
    Sep 2003
    Posts
    21
    I did go through set-by-step the KB article.

    http://support.microsoft.com/default...b;en-us;827422

    I'm somewhat convinced that my app server will not be able to talk with SQL server until the error log writes

    13:23:19.68 server SQL server listening on TCP, Shared Memory, Named Pipes.
    2004-02-02 13:23:19.68 server SQL server listening on 192.168.1.159:1433, 127.0.0.1:1433.

  9. #9
    Join Date
    Jul 2003
    Location
    Penang, Malaysia
    Posts
    212
    Hmm..just wondering..
    did all your TCP/IP settings correct? Although U can serve the web and telnet, those are on diff ports.....

    Has anyone played with your TCP/IP filtering? "PERMIT ALL" should be the setting. Under =TCP/IP Properties->Advanced TCP/IP Properties-> TCP/IP Filtering.
    Patrick Chua
    LBMS ( Learn By My Self) NPQ ( No paper Qualification )

  10. #10
    Join Date
    Sep 2003
    Posts
    21
    Yes,

    Permit all was allowed.
    I also tried the sql connection with and without TCP/IP filtering.

  11. #11
    Join Date
    Sep 2003
    Posts
    21

    ERRORLOG

    Someone please correct me if I'm wrong...
    But from the KB articles I've read on microsoft.com, I should see an BIND error message in the ERRORLOG if the SQL server is trying to listen on port 1443 but the OS won't let it?

    This should mean that I'm having problems with SQL server and not the OS?

  12. #12
    Join Date
    Sep 2003
    Posts
    21
    What is the differnce between a named instance and a standard instance? How do I find out which mine is?

  13. #13
    Join Date
    Jul 2003
    Location
    The Dark Planet
    Posts
    1,401
    Named instance :- servername\instancename
    Get yourself a copy of the The Holy Book

    order has no physical Brett in The meaning of a Kaiser . -database data

  14. #14
    Join Date
    Sep 2003
    Posts
    21

    Solution

    I like to thank everyone for their time.

    The issue was solved. It seems that installing service packs are very vital to the health of a SQL server. The behavior was definately odd. Applying SP3a solved all issues. Setting were correctly set.

  15. #15
    Join Date
    Jul 2003
    Location
    San Antonio, TX
    Posts
    3,662
    Have you tried to do what Enigma told you in the beginning, - in Server Network Configuration applet DISABLE TCP/IP library? I just fixed a similar problem, but on the client side, where a user was receiving " 'null' user is not authenticated..." error, while all settings were correct. I asked her to remove TCP/IP library from Client Network Config applet and attempt to register the server again after she re-added it to the list. Everything worked fine after it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •