Results 1 to 4 of 4

Thread: Corruption?

  1. #1
    Join Date
    Dec 2003
    Posts
    7

    Unanswered: Corruption?

    Hi all,

    I'm using Oracle 8.1.7 on Solaris 8. I've had this occur on an exported 8.1.7/RH7.3 database, too, which, BTW, just crashed hard.

    I noticed our app having intermittent problems, so I tried some tests via sqlplus. I could do selects, but if I tried deleting a few rows (no integrity issues in deleting), sqlplus just hangs indefinitely and never deletes. So I try using svrmgrl to shutdown and once again, it just hangs. So I reboot the server and things are fine (except for the new, dead machine).

    I checked the alert log, and found nothing within the last 18 months -- not even the last reboot, which seems weird. A friend suggested a pessimistic lock problem, so I also checked the v$lock table, but don't really know how to interpret it.

    How do I find out what is going on?

  2. #2
    Join Date
    Jan 2004
    Posts
    370
    If your alert log hasn't been updated for 18 months then you probably are looking at an old alert log in an old location - check background_dump_dest.

    When the sqlplus session is hanging during the delete, are other sqlplus sessions affected?

    If not, then rather than guessing it is a locking problem, I suggest the following.

    Bring up two sqlplus sessions and establish the session id of both sessions.

    Run the delete from one of the sessions.

    From the other session run the following query 4 or 5 times, about 5 seconds apart:

    column event format a20
    select seq#, event, p1text, p2text, p2, p3text, p3, wait_time
    from v$session_wait
    where sid = <session id of the delete session>

    Make sure you have the correct sid!

    You should see from the wait events if the session is stuck on the same wait, or if the event is changing over time. If it is changing, then the session isn't completely stuck.


    The wait events and their parameters are documented in the Server Reference manual.

  3. #3
    Join Date
    Sep 2003
    Location
    Milan, Italy
    Posts
    130
    Have you installed the latest patch (8.1.7.4) ?

    select * from v$version;

    I remember that 8.1.7.0 had similar problems (even strange memory errors about the shared pool) that went away as soon as i switched to 8.1.7.4, which is as stable as a rock.
    On both Solaris and Linux.

    hth
    al

  4. #4
    Join Date
    Dec 2003
    Posts
    7
    Thanks for the replies.

    Yes, the alert log was elsewhere, but still no help -- nothing unusual looking. I'm afraid to try your wait message, as this issue seems to lead to critical failures and we have only one production machine now. I'll try it off hours, though.

    We're running 8.1.7.0. We have a license (bought from another company w/ all their assets) but there is no documentation to prove we own it, so metalink is off-limits. We're planning on buying new licenses, but the purse-strings are awfully tight these days.

    Is there a work-around? Not having access to metalink has been a nightmare, but there's nothing I can do about it

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •