Results 1 to 5 of 5
  1. #1
    Join Date
    Jan 2004
    Posts
    7

    Unanswered: Error when trying to setup replication

    I am trying to setup replication on my server, but was getting an error that said:

    "The Distributor is not available Error 6. Specified SQL Server not found"

    So, I did some searching and found a couple things to check and found

    sp_helpserver....the server with id of 0 was a remote server, not the local server instance...and

    select @@servername also returned the name of that remote server!!

    I'm assuming this is my problem, but how did it get this way and how do I fix it?

    Thanks
    Last edited by Ivy; 02-04-04 at 16:57.

  2. #2
    Join Date
    Jan 2004
    Posts
    7
    Ok, I fixed the @@servername issue with:

    use master
    go
    exec sp_dropserver 'incorrect server name'
    go
    exec sp_addserver 'servername','local'
    go

    Restart sql server service.

    sp_helpserver now lists the local server as id of 0 and @@servername returns the correct server.


    HOWEVER, the same error is there for replication?!?!

    There is an entry in sp_helpserver for this:

    repl_distributor repl_distributor rpc,dist,rpc out,use remote collation 6 NULL 0 0

    Not sure if that helps with anybody trying to help me but anyway....

  3. #3
    Join Date
    Sep 2003
    Location
    Dallas, Texas
    Posts
    311
    Can you describe how you setup the Replication? At which step you get the error and how did you prepare your db server?

  4. #4
    Join Date
    Jan 2004
    Posts
    7
    Thanks for the help.

    I did not do anything except for click on the server instance->Tools->Wizards and then click Replication->Configure Publishing and Distribution Wizard

    I'm new to this server. It appears it has been messed with before but I cannot give you the details of that.

  5. #5
    Join Date
    Jan 2004
    Posts
    7
    Joe,

    I was able to get it working. For those that find this post, here is what I did.

    First, using the commands above, make sure your server is iniitally setup correct!

    Next, I disabled publishing on the local server. Tools->Replication->Publishing

    Next, I then configured the distributor for the local server. Tools->Replication->Configure Publishing, Subscribers and Distribution

    Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •