(Error FRM- 10142 No HTTP Listener started on

The issue: Forms Builder 10g( Production)for Windows seems to ignore the "Application Server URL" in Preferences/Runtime (mine is set as and always try to connect to a local OC4J instance (e.g. http://mycomputer/:8889/forms90/f90servlet)
Did anyone succeded in configuring Oracle Forms Builder 10g( Production)for Windows (coming with Oracle's Development Suite 10g)to "run form" using a remote OC4J instance, on a remote AS/Forms 10g(9.0.4) on a remote machine? It works surely fine with the default Edit Preferences/Runtime, with an OC4J instance started on the Windows local host while accessing the DB on the remote machine (running OracleAS/Forms 10g(9.0.4) and OracleDB 9i2. This is not I what need though - I need my development chain to use the remote OracleAS, and be apard of the prod chain (the remote machine), about the same thing I am able to do when JDeveloper runs in Windows on localhost and talks to the remote Oracle AS on Linux. I've tried hard for 2 days to make it work and it does not. This is what I know to date:
- In Edit Preferences/Runtime, I cannot force it to put another "default" host other than the localhost. It took though the changed default port (7777 rather than 8889) that I have changed in cagprefs.ora (Forms.port = 7777). I have found in several config (.xml) files the name of the local host but it seems it does not take it from there. Q:Is there anything in forms90.conf (e.g. mountpoints) that is causing this?
- Since the "run form" to when the error message is returned, there has been absolutely no IP exchange between the local host and the remote machine. It looks like whatever I specify in Preferences/Runtime as remote host (my "application server URL is is simply ignored by the Forms Builder, that would always try to connect to a local OC4J instance. Q: Is there any config that I've missed?


Marian Romascanu

Local: NT 4.0, Oracle Dev suite 10g(9.0.4)

Remote: LInux 9.0 (EL), OracleDB 9i2, OracleAS/Forms 10g(9.0.4)