Results 1 to 8 of 8
  1. #1
    Join Date
    Feb 2004
    Posts
    4

    Angry Unanswered: stupid 3:00AM mistake - now a daytime nightmare

    Last night, I was working on a database that will be going online. I wanted to secure said dB so... without reading a thing on access passwords or their implementation, I started setting passwords. Keep in mind this is 3:00AM.

    I believe I went Tools>Security>User accounts and made at least one account, setting also and admin password.

    The database was still empty, so I loaded it on to my server and tried to make a DSN connection with passwords. Wouldn't work, gave up, went to bed.

    Woke up. Started Access, and went to work on a different file.

    Access asks me to logon?!?!?!?!?!?!?!!!!!

    Oh oh.... in the new little box it gives me a username that I VAGUELY remember and waits for a password that I can't remember at all.

    Searched this forum, read the FAQ at Microsoft, can't find system.mdw or system.mda.

    Am I completely up the creek?

    I'm running XP Pro, MS Access 2000.

    I'd appreciate any assistance, as I cannot work on access at all. In the meantime, I'll go register myself as a moron.

    If anyone can help I promise never to set any passwords after midnight from now on.

    DW

  2. #2
    Join Date
    Sep 2003
    Location
    T.O.
    Posts
    326
    Try connecting to system.mdw then opening your db
    All code ADO/ADOX unless otherwise specified.
    Mike.

  3. #3
    Join Date
    May 2003
    Location
    Dallas
    Posts
    817
    Provided Answers: 5
    actually if you are 2000 you are automatically connecting to the sytem.mdw unless you have used the wrkgadm.exe utility that allows for specifying a seperate workgroup. If you cannot remember the admin password and you do not have users defined in the db (you mentioned an empty DB) then find the system.mdw file on your llocal machine and rename it. The restart access and it will create the system.mdw on the fly with no password enforced on the admin.

  4. #4
    Join Date
    Oct 2003
    Posts
    706

    Red face

    ... And poof!! all of that so-called "security" is gone!

    It really doesn't pay to fiddle around too much with MS-Access's idea of security. Because it isn't secure!
    ChimneySweep(R): fast, automatic
    table repair at a click of the
    mouse! http://www.sundialservices.com

  5. #5
    Join Date
    Feb 2004
    Posts
    4

    Question Re: stupid 3:00AM mistake - now a daytime nightmare

    Thanks to all for your help so far.

    The wierd thing is I cannot find system.mdw. I searched the entire contents of both my hardrives - ending in a search for *sys*.m* and found nothing.

    Oddly, at my day job (where I am now) I did the same search (computer running XP Pro with Access 2002) and found the file easily.

    I looked in the folder, to see where it should be, then logged on tom my home computer with remote desktop. Looked in the same folder, but no file.

    On my day-job computer the file is at:

    c:\Documents and Settings\myusername\Application Data\Microsoft\Access

    On home computer, same folder, but only one file "ACWZUSRT.MDT" (this files is also on work computer)

    What, do you suppose, is going on?

    DW

  6. #6
    Join Date
    Sep 2003
    Location
    T.O.
    Posts
    326
    Sorry if my earlier post was confusing. It kinda assumed that wrkgadm.exe was invoked to connect to a different *.mdw.

    Your home OS default install probably has the folder option of Do Not Show Hidden and System files selected, go to an explorer window, Tools-> Folder Options -> View, and change this to Show Hidden Sys....
    All code ADO/ADOX unless otherwise specified.
    Mike.

  7. #7
    Join Date
    Feb 2004
    Posts
    4

    Always set that way...

    Originally posted by HomerBoo
    Sorry if my earlier post was confusing. It kinda assumed that wrkgadm.exe was invoked to connect to a different *.mdw.

    Your home OS default install probably has the folder option of Do Not Show Hidden and System files selected, go to an explorer window, Tools-> Folder Options -> View, and change this to Show Hidden Sys....
    That's the wierd thing. I always have all folders set to show hidden etc. What I'm going to try is sending a copy of the system.mdw from work to home, place it in the equivilant folder at home, then try opening it.

    I cannot for the life of me figure out why I can't find the file at home. I'll let you know what happens with the work copy of system.mdw installed.

    DW

  8. #8
    Join Date
    Feb 2004
    Posts
    4

    Worked

    Originally posted by waynorth
    That's the wierd thing. I always have all folders set to show hidden etc. What I'm going to try is sending a copy of the system.mdw from work to home, place it in the equivilant folder at home, then try opening it.

    I cannot for the life of me figure out why I can't find the file at home. I'll let you know what happens with the work copy of system.mdw installed.

    DW
    I put said file into my SYSTEM folder and all is now fine. Good thing I had a "clean" copy at work. Thanks to everyone, I can not stay up until 3:00AM tonight working on my next project --- I just won't set any passwords.

    DW

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •