Results 1 to 3 of 3
  1. #1
    Join Date
    Feb 2004

    Unanswered: could not locate entry in sysdatabases

    Hey there, could someone please help me!!
    I had created a database in sql server but since then installed windows xp pro and now when i go through the microsoft sql server dsn configuration the database is not valid and therefore i cannot change the default database as it says it doesn't exist.
    So then when i type in command prompt use 'db' it says it doesn't exist but when i try to create 'db' it says that the database already exists.
    I get the error message, could not locate entry in sysdatabases for 'cti' (database name).
    When i look in mysql - data - along with master etc there is my cti.mdf and log files??
    I'm stuck???
    Is it that the files just aren't registering through sql server???
    Please help!

  2. #2
    Join Date
    Feb 2002
    Have you tried using enterprise manager or query analyzer ? Also, can you be more specific when you say "installed windows xp pro". Which version of sql server are you using ? When you configure your dsn, what are you putting in the "Server" dropdown ? Have any of your security settings changed and which type of security are you using to access sql server ? Have you tried to create a new dsn ?
    If you do not have SQL Server Books Online (BOL) installed - please do so. The majority of questions asked in the SQL Server forum could be eliminated if people had access to bol. BOL

  3. #3
    Join Date
    Feb 2004
    Hey there, i use (local) for the server in the dsn configuration.
    I have just put on windows xp pro sp1 - I orginally had an earlier windows xp pro.
    I'm using sql server 2000 sp3
    All security settings have remained the same and I've tried to do new dsn's but they still don't register that the database files aren't in the sysdatabases.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts