Results 1 to 6 of 6
  1. #1
    Join Date
    Feb 2004
    Posts
    4

    Unanswered: Prb password sys

    Hi,

    I got a problem, a big one !

    I use orapwd to encrypt sys password.

    orapwd file=passfile.ora password=oracle

    When I try to connect with sqlplus SYS AS SYSDBA
    I can put anything as password and I open the session !!!!

    but connect sys, only ORACLE password works.


    HELP !!!

  2. #2
    Join Date
    Nov 2002
    Posts
    833
    password authetification in the initORA file set to true??

  3. #3
    Join Date
    Feb 2004
    Posts
    4

    password prb

    Originally posted by osy45
    password authetification in the initORA file set to true??
    REMOTE_LOGIN_PASSWORDFILE is set to exclusive.
    which other parameter ?

    The prb is only for sys !

  4. #4
    Join Date
    Dec 2003
    Location
    Oklahoma, USA
    Posts
    354
    What version of Oracle are you using... assume pre-9i because you are able to "connect sys"

    If I remember correctly, the filename for the password file should be of the format "orapw<SID>" and in the dbs directory.

    Also, when you installed the database, did you change the SYS password by using:

    ALTER USER SYS IDENTIFIED BY oracle



    As to the "problem" you are encountering:

    When you log in as SYS AS SYSDBA with the REMOTE_LOGIN parameter to anything but NONE, you enable OS authentication to occur. This means that a user can log into the database if he/she is one of the following: the owner of the Oracle process (program), or a member of the same group of process owner.

    In either instance, authentication (i.e., password verification) does not occur within the database, but Oracle relies on the OS to make sure the user logging in has been validated. What this means is that eventhough Oracle asked you for a password, it already assumed a valid connection and didn't actually require the password.

    When you simply CONNECT SYS, you are going directly to the database and whatever password SYS has been assigned in the database (not the orapwd) is going to be used.

    Hope this helps sort things out for you.

    JoeB

  5. #5
    Join Date
    Feb 2004
    Posts
    4

    password sys

    Ok you're right !! I test it with a non administrator login and it works !

    How can I not use this option "remote login" ?

    THanks

  6. #6
    Join Date
    Dec 2003
    Location
    Oklahoma, USA
    Posts
    354
    In the init.ora file, set:

    REMOTE_LOGIN_PASSWORDFILE=NONE

    JoeB

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •