Results 1 to 2 of 2
  1. #1
    Join Date
    Feb 2004

    Question Unanswered: database link 8i to 9i

    I've done the dblink from 9i to 9i w/o problems, and created synonyms, etc. but now I am going from 8.0 to 9.2

    The link is there. The DBA says that it's working. I've created a synonym like how I did 9i to 9i (create synonym syn_table_name for when I create the table in the 8.0 environment (create table x as select * from syn_table_name...) I get ORA-03115: unsupported network datatype or representation, a msg from the 9i db.

    So, either 8i can't link to 9i properly, or the syntax is different than 9i to 9i for creating the synonym itself and/or the syntax is different for creating the table in the 8i db.

    Any clues? Thanks!

  2. #2
    Join Date
    Feb 2004

    Lightbulb progress but not really

    So I've narrowed the problem down to a couple of tables from the 9i db that I can't link over to the 8i db. Other tables came over fine. So I'm thinking that there must be something in these 9i tables that are distinct to 9i. I thought of the timestamp field but I tried just bringing over one plain jane numeric column to test my theory, but that didn't work. So I'm back on the drawing table.

    Of course luck has it that the 2 tables (and growing) that are the most important to link over to the 8i db are the ones I can't bring over.

    I also thought that maybe these tables are too big, but I tried just bringing over the numeric column and weeding it down to just approximately 1,000 records, but still, ORA-03115.

    Let me know what you guys think. Thanks,

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts