Results 1 to 3 of 3
  1. #1
    Join Date
    Dec 2003
    Posts
    11

    Unanswered: Starting psql 7.4.1

    Hi.

    Well, I just upgrade my psql 7.3.3 to psql 7.4.1.

    When I trying to start the psql, I get this message:

    FATAL: XX000: failed to initialize lc_messages to " "
    LOCATION: InitializeGUCOptions, gu.c:1866

    I dont know why I get this message, because last tuesday it was working fine.

    I looked at the postgresql.conf file, and the lc_messages setting is the default,
    lc_messages = 'en_US.UTF-8'.

    What could be the problem??, I just changed some settings defaults for logs.

    Thanks for any help.
    Pablo Velasquez Rivas
    Computer Science Engineer - ITCR

  2. #2
    Join Date
    Oct 2003
    Location
    Slovakia
    Posts
    482

    Re: Starting psql 7.4.1

    Originally posted by pvelasquez
    Hi.

    Well, I just upgrade my psql 7.3.3 to psql 7.4.1.

    When I trying to start the psql, I get this message:

    FATAL: XX000: failed to initialize lc_messages to " "
    LOCATION: InitializeGUCOptions, gu.c:1866

    I dont know why I get this message, because last tuesday it was working fine.

    I looked at the postgresql.conf file, and the lc_messages setting is the default,
    lc_messages = 'en_US.UTF-8'.

    What could be the problem??, I just changed some settings defaults for logs.

    Thanks for any help.
    try "unset LANG" in shell and then try start psql again

  3. #3
    Join Date
    Oct 2003
    Location
    Slovakia
    Posts
    482

    Re: Starting psql 7.4.1

    Originally posted by ika
    try "unset LANG" in shell and then try start psql again
    If previous command didn't solved you problem try "export LC_MESSAGES='POSIX'"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •