Results 1 to 4 of 4
  1. #1
    Join Date
    Feb 2004
    Location
    INDIA, CHENNAI
    Posts
    7

    Unanswered: Set Xact_abort On

    Hi,

    How to set "SET XACT_ABORT ON" Property in SQL SERVER GLobally, such that any connection to MS SQL SERVER has this property ON?

    Note : By Default this property is OFF.

  2. #2
    Join Date
    Jan 2003
    Location
    India
    Posts
    523

    Re: Set Xact_abort On

    Originally posted by nhariharan
    Hi,

    How to set "SET XACT_ABORT ON" Property in SQL SERVER GLobally, such that any connection to MS SQL SERVER has this property ON?

    Note : By Default this property is OFF.
    I think this should work:
    alter database db_name set SET XACT_ABORT ON

  3. #3
    Join Date
    Feb 2004
    Location
    INDIA, CHENNAI
    Posts
    7

    Re: Set Xact_abort On

    No. This option does not work .

    Only the following options work with alter database db_name SET command.

    ANSI_NULL_DEFAULT { ON | OFF }
    ANSI_NULLS { ON | OFF }
    ANSI_PADDING { ON | OFF }
    ANSI_WARNINGS { ON | OFF }
    ARITHABORT { ON | OFF }
    CONCAT_NULL_YIELDS_NULL { ON | OFF }
    NUMERIC_ROUNDABORT { ON | OFF }
    QUOTED_IDENTIFIER { ON | OFF }
    RECURSIVE_TRIGGERS { ON | OFF }

    Any other suggestions pls?

  4. #4
    Join Date
    Nov 2003
    Posts
    94
    This option is carried by the transaction, not the database or table, and can only be set at run time for each transaction.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •