Results 1 to 5 of 5
  1. #1
    Join Date
    Jan 2004
    Posts
    10

    Unanswered: Cdonts Big Help !

    I need someone to please check the attachment code to see if it is working. I have been trying to make to work and still can't. Someone tested and told me that is was working, but when I try to run it it does not even display the error messages that are in the code.

    I really need someone who could take a few minutes and help me to get this thing runnig. The send request to, is a drop down menu from a recordset of a table who got all the emails and names the user is supposed to select to send the request information. This had run before but the message came with no data of the request.

    I really would appreciate some help.

    Thanks.
    Attached Files Attached Files

  2. #2
    Join Date
    Nov 2003
    Location
    Christchurch, New Zealand
    Posts
    1,618
    should line 352 be

    IF(errCheck = 1)THEN

    not

    IF(errCheck = -1)THEN

    being that you have said in line 214

    errCheck = -1 'reset the error checking flag -1=no error, 1=error

    ????

  3. #3
    Join Date
    Nov 2003
    Location
    Christchurch, New Zealand
    Posts
    1,618
    also

    you have line 211 saying

    If Trim(Request.Form("submit")) <> "" Then

    but line 1107 has your button called submit2

  4. #4
    Join Date
    Jan 2004
    Posts
    10

    Sending with no information

    Thanks for your help, it really help.

    Now I got a problem, the form is sending but without the information only the HTML but no info from the user. I was wondering; Do I have to declare variables for the information from the recordset? If it is yes, where sould I start declaring them and how?

    PS: The info that is not sending is the one from the table from a recordset.

    Thanks.


    Originally posted by rokslide
    also

    you have line 211 saying

    If Trim(Request.Form("submit")) <> "" Then

    but line 1107 has your button called submit2
    Attached Files Attached Files

  5. #5
    Join Date
    Nov 2003
    Location
    Christchurch, New Zealand
    Posts
    1,618
    so you are saying for example....
    Code:
    strMessage = strMessage & "<br>City: "&city
    produces
    Code:
    <br>City:
    but nothing else?

    If this is what you mean (and having looked at the code I think it is) the problem is that you have not set any value for the city variable.

    When you get a recordset it doesn't automagically assign the values int he recordset to anything, you need to do that yourself. So in this case you would want something like
    Code:
    city = rsUserinfo("city")
    alternatively you could use the recordset values directly, like this
    Code:
    strMessage = strMessage & "<br>City: " & rsUserinfo("city")
    HTH

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •